[SOLVED] PC sometimes boots and displays to bios, sometimes no display, never to windows

Jan 17, 2022

Okay so as the title suggests, my pc turns on, but never gets to windows. It was working fine until I decided to update 3 pieces of hardware. Specs below with an * are new.

CPU- Ryzen 9 5950x
CPU Cooler- iCUE H100i Elite Capellix*
Mobo- Aorus x570 Elite
GPU- MSI 3080 Gaming X Trio
Memory- 4x16 Gb 3600MHz Corsair Vengeance RGB Pro* (went from 2 to 4 sticks)
Storage- Western Digital 1 Tb NVMe
PSU- Corsair RM1000x* (went from 850 to a 1000)

As mentioned, the PC will turn on, all fans spin and RGB turns on, but it’s a hit or miss if any display shows. When it does, I get the Aorus Screen and can access the bios. The motherboard will detect RAM, but not all 4 sticks. I tried each stick separately but couldn’t get a display, even the old working sticks. I tried plugging the old ones back in but still could not get it to go to windows log in. I’ve tried testing each slot and still can not determine why it will not go to windows. I tried rewriting the AIO in case that was the issue, including changing the fans used for the CPU Fan with Radiator Fans and even case fans and the pump. Currently I have a case fan as the CPU_FAN and the pump header plugged into the CPU_OPT. Usually the computer turns on and stays on, but a handful of times everything would kick on and then restart about 3 times. I’ve reseated the CPU, the GPU, checked to make sure BIOS detected my boot drive (it did), I’ve flashed and updated the bios on the mobo, took mobo battery out to clear CMOS, ensured XMP was on, but at this point I’m at a loss. I’m not sure why it won’t go past the bios or display. It won’t get to windows with the original RAM either.

Update: I’ve cleared the CMOS by jumping and went to only two sticks of RAM (both old and new) and still cannot get past the bios. I save my edits and the system reboots, displaying the Aorus screen with the ability to go to bios, about 2-3 times, then displays nothing after the logo disappears.