Question PC Staying ON when shut down (fans and RGB) until I press down power for a few seconds

Jan 22, 2022
1
0
10
0
As the title says.
Did a windows update and an Asus Armoury Crate full update which it updated pretty much everything in it, not just the suite itself. I had been away for a week so it had quite a lot of updates.

Anyways, I’ve NEVER had this issue - it’s a 1 year old custom build and I have fast boot disabled.

As the title says, when I shut down my PC, the fans still spin and the lights stay on. My monitor goes off, the keyboard turns off and so does the mouse..but not the pc itself.. The only way the pc will fully turn off is if I hold down the power button for about 5 seconds. Then I can press it again and boot up as normal, no issues.
  • fast boot disabled
  • RGB is set to turn off in the shut down mode tab in Asus armoury crate
I am not sure how to roll back the asus drivers it updated, or the windows update - or if that was even the culprit of the two of them. Nothing in my BIOS has changed either, and aside from this, I have no other issues.

Specs:

CPU: 5900x
GPU: ASUS TUF OC 3080



 
Jan 22, 2022
2
0
10
0
Hey i have exactly the same issue right after the asus armoury update , before this i noticed my pc stop responding , forcing me to manual reset in order to retain control, now i cannot shut down without long pressing the power button, the fans and the rgb stays on, my monitor kb and mouse turn off. Asus just screw up with something, this is for sure because of the armoury updated
I have Asus tuf b550 plus , 5800x , 6900 xt, we also exactly the same memory.
Have you managed to find any information ?
 
Jan 24, 2022
3
0
10
0
i am having the same issue. pc also will get stuck on restart screen if i try to restart. fast boot also disable. i also cannot downlod my radeon update for my gpu it hangs up…pretty sure the armory crate update is bugged
 
Jan 22, 2022
1
0
10
0
I am having the exact same issue, if you uninstall Amoury Crate with the official uninstall tool it fixes the problem.
I already sent asus an email about this
 

ASK THE COMMUNITY