Question PC stays on, no video signal

Dsella

Distinguished
Sep 3, 2013
40
3
18,535
0
I've just installed an i9 9900k and now I'm having an issue where I turn my PC on and get no video signal. I've tried reseating my RAM sticks as I saw suggested.. no luck there.

My tower stays on, lights go as they usually do, but my monitors receive no signal. Nothing else was switched besides the CPU and I also installed a HYPER 212 cooler on top of it.

Specs:
Core i9 9900k (Formerly an it 8600k)
ASUS GTX 1070
HYPERX 16GB DDR4 (2x8GB)
1TB Samsung EVO PLUS M.2

Any ideas? Tower has no problems of rebooting itself or anything else.. simply no video signal to my monitors. HDMI to both. One an ALIENWARE 240hz, other an ASUS 60hz for side screen.

Thanks
 

Dsella

Distinguished
Sep 3, 2013
40
3
18,535
0
Power cables don't appear to be an issue. I've tried the following since post:

Took GPU out, took out CMOS battery, put it back in.. attempted to boot plugged in to the motherboard HDMI slot with video card out, still no luck..

I've also tried just one stick of RAM in every slot, no luck again..
 

Dsella

Distinguished
Sep 3, 2013
40
3
18,535
0
So, based on what I've just experienced and saw through Google.. it appears to be something between the chipset on my mobo and the i9 9900k itself.

I searched "i9 9900k msi z370 gaming pro carbon" and it appears you really want a Z390 chipset for i9's.. and unless you have a very nice Z370 chip, something about the power distribution in the mobo not exactly made up for 8 core CPU's and blah blah blah.. not sure the exact technicalities of it.

I'd bought a generation old i9 to hopefully make this rig a bit better and prolong the mobo as it was on sale for $310 on black Friday but apparently I'll be returning it and just making the leap to 10th gen & the new LGA socket.

If anybody has any other suggestions/input much appreciated, thanks.
 
Oct 29, 2020
24
3
15
0
According to Compatibility List,
It's Compatible , but for a 9th Gen Chip to be supported BIOS version should be 7B45vA6 or above ,Check Here
  1. You need to use an 8th Gen Chip(Use your 8600k) to upgrade Motherboard BIOS to support 9th Gen.
  2. After the updating BIOS swap 9900K chip back in & check !
-Hope this helps !
 
Last edited:
Reactions: Dsella

ASK THE COMMUNITY

TRENDING THREADS