Question PC stopped connecting to monitor

Dec 30, 2020
1
0
10
0
I’ve had this pc for 2 and half years, it’s far from great but it worked for my needs, this is the first major problem I’ve encountered.

The problem:

My pc was not loading up, it was constantly staying on the gigabyte loading screen so I was pressing the on and off button quickly around like 15 times, and now it will not connect to any monitor.
When I turn it on I see that the motherboard lights up, all my fans spin and it looks as if it’s working but it will say there’s no signal on my monitors.

Things I have tried:

I have tested the monitors and the hdmi cable with my laptop and they work fine, tried both the gpu and motherboard hdmi slot and doesn’t change anything, both not working.
Reset the bios on the motherboard
Cleared CMOS
Tested each slot of RAM with each RAM stick
Booting without the gpu
Have taken apart and reinstalled every component

The specs:
AMD Ryzen 3 2200g CPU
Gtx 1050ti
4x4Gb of Ballistix sport LT BLS2C4G4D240FSB DDR4
WD 1 TB Hard drive
Gigabyte GA-AX370M Gaming 3 motherboard
EVGA 500 W1 power supply
Kingston A400 120GB SSD

I really don’t know what to do any advice is appreciated:)
 
Could be the GPU. The only way to know is to test the GPU in another system or test another GPU in your system.

Could be the PCIe Slot. Try the other PCIe Slot.

Could be the PSU that decided to crap out after 2 years and a half not giving power to your GPU so no signal.

Since you tried the motherboard graphics port and it did not work I'm more inclined to say it's the PSU or the motherboard PCIe Slot / Motherboard.
 

ASK THE COMMUNITY