Question PC stopped POSTing randomly

Jul 12, 2021
10
2
25
0
So suddenly a few days ago I tried turning on my PC but all I got was 3 short beeps from the speaker connected to my mobo.
I switched up the slots and reinstalled the ram but when I tried turning on my pc I got 1 long beep.
I made sure everything was connected properly, and then I tried turning on the pc again but this time I didn't get any beeps, the monitor would just show "no signal"
Since I have an iGPU as well I tried connecting my monitor to that after removing my dedicated gpu but it didn't work.
All of my fans spin normally. and I already tried resetting my cmos.
This all just happened suddenly, the pc was working perfectly the night before and I switched it off normally.
I did some dust cleaning and replaced my pc fans about 2 weeks ago, but the pc ran completely fine for a whole week and a half till it decided to not work, and the new fans aren't even connected to the motherboard, they're connected to an external controller which is connected to a sata power cable from the psu.
I think that my ram might be the one at fault here since I got an error code for the memory first.
I've been looking if anyone from my friends/family could borrow a stick of ddr4 ram but it seems like nobody has any, so I'm considering to take the pc to the technician so this post is really my last effort.

Specs: Rx 580, R5 2400g, B450m HDV, 16gb 3000mhz. EVGA 500w, 500gb ssd...
 
Jul 12, 2021
10
2
25
0
Turns out one of the sticks was broken or something, it was stopping any other stick installed from working for some reason
 

ASK THE COMMUNITY