Question PC stopped working out of nowhere: the mobo's light is on but it does not boot & none of the fans spin ?

May 25, 2021
1
0
10
0
I bought a desktop some weeks ago just to get the GPU that came with it. Considering the gpu's price and price I could sell the other parts for, it was a good deal.
As soon as the pc arrived I tested and everything was working; even did some stress testing to be sure.
Then I removed the GPU to put it on my mining farm and removed one of the ram sticks to check its exact model. Tested the pc again through the onboard card (without one ram stick and gpu) to confirm some details on speccy: still working.
Turned the pc off, turned the psu off, removed the second (and last) ram stick to take pictures of it. Closed the case and put It inside my wardrobe. Then, as I was listing each of its parts for sale I wasn't sure of some details that seemed important to mention, thus decided to open the case again to check the model of the cpu's heatsink and then open speccy again so that I could be sure of something. When I try to turn it on this time guess what? Not working. Mobo light is on but it doesn't boot nor any of the fans spin.
At first I actually forgot to put the ram sticks back and it didn't boot obviously, but in a few seconds I realized and fixed it. Thought this time it'd boot for sure but nope, same thing.

What I tried so far:
-Double checked if all cables are attached correctly
-Tested the two memories on all the four available slots. Both individually and together.
-Disconnected the power wire and tried shorting the power pins with a screw driver, thinking maybe something I did pulled the wire too roughly and made it faulty.
-Tried to use another PSU that I know to be working

The PC specs:
Motherboard Asus P8Z77-V LX2 LGA 1155
i5-3570k with a deep cool gammax as cooler
16gb ram (2x8) HyperX Fury
SSD 120gb sandisk plus
600w PSU
DVD Drive

I have no idea what could be. I'm used to dealing with pcs. Have built tons. Swap parts on a regular basis. Run a mining farm. So you can imagine I took all the reasonable precautions. Don't know what I did that made it stop working like that.

I speculate the problem lies either on the MOBO or the CPU because It's unlikely both ram sticks bricked and I tested with another PSU. And it's more likely to be the MOBO since I didn't mess with the cpu at all. The most I did was putting my hands on its big ass heatsink to check something.
I'd like to test the cpu on another mobo and the mobo with another cpu, but their socket is ancient so I lack the necessary parts.
 
Last edited by a moderator:

Aeacus

Glorious
Ambassador
I'd like to test the cpu on another mobo and the mobo with another cpu, but their socket is ancient so I lack the necessary parts.
Without it, it's impossible to tell which of the two is toast. You could try to reseat CPU though. And check any bent CPU pins when you're at it.

If CPU reseat doesn't work, then your guess is as good as mine. Though, there is still one plausible cause: ESD, during this:
putting my hands on its big ass heatsink
If it was ESD, your MoBo is most likely toast since MoBos are the 1st ones to go, usually.
 

ASK THE COMMUNITY

TRENDING THREADS