Question PC stuck at white VGA LED, cant access bios, no monitor signal

Nov 11, 2022
2
0
10
0
Good day,

I was playing a game on demanding settings a few days ago and my fans went wild for like 5 minutes, afterwards my PC crashed and it wouldnt turn on anymore,
so I plugged the power cord in and out again.
It went on again, but now the white VGA LED on my mobo is constantly on and i cant get a signal on my monitor anymore.
All of the fans are working normally, all the lights on my computer or gpu also work, the light on any connected usb devices also light up.
Accessing BIOS also doesnt work.
And my PC is now more than 2 years old and I never had any debug leds yet, only moments where my gpu stopped working properly when i played games full of mods, and then had to use the shortcut to reset it.

I have no other PC or PC parts at my disposal and also cant ask anyone to try my PC parts out to see if my gpu died, i was thinking about visiting a repair shop, but they charge 100 euros just for the inspection alone without repairs, in the worst case scenario if I have nothing else to try, i was considering to buy a gpu and test if mine died and then replace it with the bought gpu.

Those are the things I've already tried with no success:
-Start the PC with no GPU, turn it off and start it again with the GPU now inside.
-Trying to get into BIOS while the GPU is out.
-Putting the ram sticks in and out
-Putting only one ram stick in at once
-Checking if it the HDMI cable isnt working.
-Trying to see if my monitor doesnt work by connecting my PC to the TV screen
-Cleaning my PC
-took out the cmos and put it back in

I would be grateful for any recommendations or help i can get, because I've been searching on a lot of forums or sites, but cant find any solution.

Those are my specs:
Mobo: MSI B450M Pro-M2
GPU: Zotac Nvidia GeForce RTX 2070 Super
CPU: AMD Ryzen 5 3600
RAM: 2x8 gb ddr4 ballistix 2400 by micron
 
Last edited:

ASK THE COMMUNITY