Question PC stuck on bios splash screen

Jan 12, 2023
When I restart my pc it gets stuck on the bios splash screen
If I press the button to enter bios before a certain amount of time I can enter bios but if I leave it to wait to boot it gets stuck on the splash screen and no input works
when im in bios everyhitng works fine, but when I try to boot into os it just freezes
I have tried multiple different drives including trying windows 10, 11 and ubuntu as well as trying bootable usbs and the same thing happens. (PCIE gen 3, pcie gen 4, 2.5" ssd, hybrid hdd, 2 usbs)
I have tried removing ram and trying each one individually
did multiple cmos battery resets to try and get it to work
updated bios
tried with everything unplugged
tried without graphics card
Tried reseating cpu
tried CSM on/off
Safe mode on/off
boot error light is on
Case: Corsair 4000D airflow
CPU: Ryzen 5 7600X
MB: Gigabyte B650 Gaming X AX
Ram: Kingston Fury Beast RGB 32GB (2x16GB) 5200MHz CL36 DDR5 EXPO
GPU: MSI RTX 2080 Ti Gaming X Trio
PSU: Corsair HX850i

Dont know what to do please help