Pc to tv via HDMI no sound

craiggill2003

Distinguished
Apr 8, 2010
8
0
18,510
0
Im connecting my pc to tv as a monitor via hdmi to hdmi but not perminantly, normal monitor hp W1907s.
TV sony bravia KDL40D3500 - when connected it works and looks amazing but i cant get the sound to work any help would be great thanks.
 

strangestranger

Splendid
Jan 31, 2006
4,680
0
22,860
26
Hmm, well at least the drivers are installed correctly.

For some reason it is not recognising it as being plugged in though.

I am unfortunately not used to onboard devices but perhaps you could check in the BIOS to see if there are nay options related to sound in there.
 

robz0r

Distinguished
Apr 8, 2010
3
0
18,510
0
Hi

I'm unsure about you're particular card, with it being built in to the motherboard, but usually you need a S/PDIF cable to go from your soundcard to your graphics card in order to transmit audio through HDMI. Unfortunately I don't know if this will apply to your graphics card, but it's usually the case. If you cannot get it to work the easiest fix would be to use a separate audio cable going from your PC to the associated HDMI input.

I hope this helps.
 

flyinfinni

Distinguished
May 29, 2009
2,043
0
19,960
74
With the new ATI cards, you shouldn't need anything connected from sound to video for HDMI Sound. I would check and make sure you have a good HDMI cable. Try another one if you have a spare. If its detecting it as disconnected then it seems like its a cable or connection issue as opposed to drivers.
 

strangestranger

Splendid
Jan 31, 2006
4,680
0
22,860
26


Just clarify, you have never needed to do this with ati cards for several years.
 

robz0r

Distinguished
Apr 8, 2010
3
0
18,510
0
Sorry guys I guess its obvious I'm not familiar with ATI cards but thanks for correcting me. I'll know better in future :)
 

flyinfinni

Distinguished
May 29, 2009
2,043
0
19,960
74
No problem. The new 5xxx series cards can actually bitstream full HD audio over HDMI now- very fancy stuff, and part of the reason they are a great buy for an HTPC these days.
 

howardp6

Distinguished
Aug 19, 2008
418
0
18,810
24
Try setting the TV as the primary display. The ATI drivers will only support one audio output. If the monitor is the primary display your PCs speakers will work, but you will get no audio on the HDMI cable.
 

c210pilot

Distinguished
Aug 2, 2006
22
0
18,510
0
Sorry for opening up an old thread, but need to throw in my two cents because I "had" the same problem and Gigabyte is slow to help.

Originally I had a DVI-HDMI cable and toslink cable from computer to my Denon 3808ci receiver, and then monitor to my Sony KDS-50A2020. Slow on the build, I never had a DVD player installed in the computer and assumed that the downloaded content that I was watching was standard def.

Then I installed a dvdrom and ran an HDMI cable to the receiver. To my surprise no Dolby Digital or DTS. As before, I was only able to passthrough 2 ch pcm. I reinstalled device drivers from Gigabyte and Realtek, no go.

Finally called Gigabyte and discovered the problem, or so I thought. Tech support insisted that I need to put in the driver CD and install Dolby Control Center. There ain't no Dolby Control Center on the Application menu. So we perused the cd and low and there was a folder named Dolby. I installed the 64 bit version, got off the phone and played a DVD. Guess what, still 2 ch pcm. Went into Dolby Control Center, chose the option for Digital Output S/PDIF and hooked the DVI-HDMI cable and toslink cable back up. and YAY! IT ALL WORKS!

One other werid thing I forgot to ask Tech support concerning the HD manager. It showed the HDMI as being installed with Microsoft drivers, device manager confirmed this. When I checked Digital Out, it showed Realtek.
 

Similar threads


ASK THE COMMUNITY