Pc turns on but doesn't display anything

Axonz

Honorable
May 19, 2012
8
0
10,510
0
My computer will no longer display anything but still turns on. After a series of crash reboots whilst playing games, it no longer fully reboots. The leds turn on as do the fans but nothing gets displayed. If my keyboard is connected it will flash it lights as if it keeps loosing connection.

Specs:
Intel Core i5 4690K Haswell Refresh Processor 3.50 GHz (Overclocked to up to 4.3GHz)
Gigabyte Z97X-SLI Motherboard
8GB Corsair PC3-12800 1600MHz DDR3 Memory (4 x 2GB sticks)
NVIDIA GeForce GTX 770 2GB
Corsair 600W PSU

What I've tried is changing my dvi cables
Reseating ram and gpu
I've tried several different power sources and replaced my power cable
I've removed my gpu and tried using the motherboards integrated video outputs
Nothing seems to be working and I'm getting angry and impatient. Not sure what else to try.

Any help would be appreciated

Thanks
 

larkspur

Distinguished
Clear CMOS to reset the board to default (see your motherboard manual for how to do this) and try and boot-up using the integrated. If that works then reinstall the GPU and see if you can get it to come up again. Also try booting with one stick of RAM installed. If that doesn't work try another stick all by itself. It could be a lot of different things.
 

Axonz

Honorable
May 19, 2012
8
0
10,510
0
Well clearing the CMOS didn't work, neither did changing the ram and booting with one at a time.
I still get no response from my monitors even on integrated
 

ASK THE COMMUNITY