Question PC turns on but no booting & monitor,mouse and keyboard doesn't work.

Sep 21, 2019
9
0
10
0
Hi, First of all sorry for my english. When I start my PC, it runs but monitor,keyboard and mouse doesn't work. Fans are spining and motherboard has lighting. If I wait like 15 minutes then it boots up and everything works like monitor,mouse and keyboard. I have tried other PSU,CPU,RAM,GPU (tried on onboard VGA), HDD. I also changed the CMOS battery. But still I cant solve the problem. Looking for help. Thanks
 
Hi, First of all sorry for my english. When I start my PC, it runs but monitor,keyboard and mouse doesn't work. Fans are spining and motherboard has lighting. If I wait like 15 minutes then it boots up and everything works like monitor,mouse and keyboard. I have tried other PSU,CPU,RAM,GPU (tried on onboard VGA), HDD. I also changed the CMOS battery. But still I cant solve the problem. Looking for help. Thanks
What is system configuration: motherboard, CPU, memory, GPU, PSU, drives, etc.

Are you getting any trouble lights on the motherboard for CPU, GPU or memory? if there are no trouble LED's, can you hook up a speaker to the speaker contacts to listen for 'beep' codes?

Other than that, all the usual should be checked/double checked: all connections, memory, CPU inserted and latched, are all standoffs in place and any unused ones removed, are mounting screws securely tightened.
 
Sep 21, 2019
9
0
10
0
What is system configuration: motherboard, CPU, memory, GPU, PSU, drives, etc.

Are you getting any trouble lights on the motherboard for CPU, GPU or memory? if there are no trouble LED's, can you hook up a speaker to the speaker contacts to listen for 'beep' codes?

Other than that, all the usual should be checked/double checked: all connections, memory, CPU inserted and latched, are all standoffs in place and any unused ones removed, are mounting screws securely tightened.
Motherboard: MSI Z77A-GD55
CPU: i5 3570 (also tried G630)
GPU: GTX 750 (also tried onboard)
PSU: Thermaltake 430W (also tried 350W cant remember the psu's brand)
RAM: I have 4x8 GB DDR3. ( Mb has 4 slot and I tried one by one to every slot. I guess It's not about the RAM.)
HDD: 1x 320 gb + 1x 80 gb (tried to start without HDD's still same)

Motherboard doesn't have any error code area and It doesn't beep. Haven't tried to hook up any speaker yet.

The thing is my RGB mouse has lighting but weirdly. Like if I right click It goes green led, if I left click it goes red and If I click both of them at the same time it goes red+green light. It gets electricty. It is a very weird problem lol
 
Last edited:
Sep 21, 2019
9
0
10
0
Try re-installing the mobo BIOS maybe?
I can't do it now because I can't get there.

Also I tried the run PC with only MB,CPU,RAM and PSU for sure. It doesn't turn off (I believe it means CPU,RAM and PSU ok) but nothing comes to monitor. So there is only motherboard left. But I wanna make sure about it. Does my motherboard's some chip is dead?
 
Sep 28, 2019
1
0
10
0
I can't do it now because I can't get there.

Also I tried the run PC with only MB,CPU,RAM and PSU for sure. It doesn't turn off (I believe it means CPU,RAM and PSU ok) but nothing comes to monitor. So there is only motherboard left. But I wanna make sure about it. Does my motherboard's some chip is dead?
You have to do a cmos reset. Unplug the power plug by putting Jumper on the JBAT for 10 seconds and then reconnect everything. Mostly the pins are under the graphics card
 
Sep 21, 2019
9
0
10
0
You have to do a cmos reset. Unplug the power plug by putting Jumper on the JBAT for 10 seconds and then reconnect everything. Mostly the pins are under the graphics card
There is a JBAT area but its empty. I mean nothing connected over it. And I took my brother's PC's battery and put in my PC. Still no work. Also his PC doesn't have JBAT pin either.
 
Sep 21, 2019
9
0
10
0
And I dont think it is about the CMOS battery or something close to it. Because I tried like 4-5 battery and have pushed the CMOS clear button on mo-bo several times.
 
Sep 21, 2019
9
0
10
0
! - UPDATE - !
My PC was trying to Overclock RAM or CPU but my ram and cpu doesnt have OC option. I have solve the problem by updating BIOS firmware. If does anyone have problem like this. Try the solution.
 

ASK THE COMMUNITY

TRENDING THREADS