• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question PC Turns on but no display from GPU. VGA light on motherboard is on.

Jul 16, 2021
3
0
10
0
Hello. One day I was sitting on my desktop when all of a sudden the display just went blank. I had run into this issue before but turning the PC off and back on usually fixed it. This time the display would not come back on but the fans still spin on the GPU and the VGA debug light on my motherboard is on. I've tried everything. Removing ram/changing ram slots, clearing CMOS, switching PCIe ports, even sending in my MB to Asus for repairs, but got it back saying they couldn't replicate my issue but did a BIOS update. After setting everything back up I still had the same issue. Not sure what else to do.
Specs:
Asus Tuf Gaming X570-Plus
AMD Radeon RX 590 Fatboy
AMD Ryzen 9 5900x
Corsair RM 750
Corsair Vengeance RGB Pro 3000 16 GB
 
Jul 14, 2021
53
5
45
0
The problem is with the PSU, i had the same issue where all of my components work but no display then i found out that my PSU was not enough to power up my GPU properly so i got a better PSU with a good rating and it worked !
 
Reactions: CountMike
Jul 16, 2021
3
0
10
0
The problem is with the PSU, i had the same issue where all of my components work but no display then i found out that my PSU was not enough to power up my GPU properly so i got a better PSU with a good rating and it worked !
Thanks for the reply. How many watts was your old psu before you changed it? How many watts was the new one? I just find it hard to think that 750 watts wouldn’t be enough for everything.
 
Jul 14, 2021
53
5
45
0
my new one is 850W PSU with a gold rating . i advice you to get PSU which has more than 850W and a good rating like gold thanks.
 

ASK THE COMMUNITY