Question PC turns on, but no display or led on peripherals.

reapzstar

Reputable
Jan 31, 2016
86
0
4,640
4
Hey there!

When wanting to turn my PC back on after like a minute(forgot to do stuff)it just doesn't turn back on..
Sometimes it does when I clear the CMOS, but it only helps 5/10 times.
So, it happens like this:
It powers up properly, then powers down in the same fashion.
But absolutely randomly, it does this strange thing where the monitor just doesn't want to display anything and the leds on the mouse, keyboard, mousepad won't turn on either.. It makes me really mad to tell the truth.
Needing to clear CMOS whenever I want to just turn it back on for a minute is quite bad and unacceptable.
When it first happened, I let it sit for a night, then did a CMOS clean in the morning, and it worked fine for like 2 days.
Then yesterday night, I turned it off, then forgot to do something, and wanted to turn it back on after like a minute has passed, but wasn't succesful...
I accidentally pushed the "H" on the keyboard, and the whole keyboard lit up, which I don't think it should when the system is turned off.
I would also like to get some thoughts on that from you guys.
Before I forget, a few components of the system just have been bought like a week ago(mobo,cpu,ram).
I wouldn't say it's the PSU, since when I game, everything is fine for hours.
I couldn't think of anything to be honest, since when it does turn on, I wouldn't be able to tell a single bad word about the system, even if I wanted to.
Specs:
Asrock H370M Pro4
2x8GB Kingston HyperX Fury 2666Mhz
i5 9600(Non-K)
Corsair VS550(yes, I know it's quite bad, but has been getting the job done for quite some time now.. planning to make an upgrade next month, even though it's not causing the problem imo)
ASUS GTX 960 DC2 OC 2GB
WD 5400RPM 1 TB

Please tell me a solution, I'm getting frustrated over this...
 

ASK THE COMMUNITY

TRENDING THREADS