Question PC turns on but no signal to monitor ?

Jul 12, 2020
3
0
10
0
Hello,

I have a PC running on Gigabyte motherboard with 4GB DDR2 RAM with 1TB Seagate HDD, intel Pentium
Not long time ago, the PC runs smoothly but now it won't display screen.
Below are the condition
  • The DVD tray can get out after I pressed the button
  • The fan runs smoothly, not too fast
  • There is no signal on the monitor, I have tried changing the monitor, the screen still didn't show up
  • Changed the VGA cable, still no display
  • Reseating the RAM, still no luck
  • Removing all the RAM from the motherboard, my other PC beeps when I did it but the PC that has the problem does not beep after there is no RAM installed
  • Changed power supply and making sure my house's voltage is all good, but still no display
What should I do to fix this "no signal" PC?
Any helps would be very appreciated.
Thank you!
 

popatim

Titan
Moderator
Please list your systems specs for us with make # model#'s of the various parts.

When you start it up, do you hear the normal windows startup sound?
Is the monitor connecting to a graphics car (GPU) or the motherboard video ports? If it's a GPU then ty connecting to the motherbd ports.

Thank you.
 
Jul 12, 2020
3
0
10
0
Please list your systems specs for us with make # model#'s of the various parts.

When you start it up, do you hear the normal windows startup sound?
Is the monitor connecting to a graphics car (GPU) or the motherboard video ports? If it's a GPU then ty connecting to the motherbd ports.

Thank you.
Thank you for your reply,

When I start it up, I do not hear the normal Windows startup sound.
The monitor is connected to the motherboard video ports since I do not have a GPU installed.
 

ravin_29

Commendable
Mar 24, 2019
56
0
1,530
0
May be try cleaning RAM slots if you have IPA cleaner, spray it on RAM slots and try RAM in each and every slot a few times again and again and see if it works.

try resetting cmos settings
 
Last edited:

ASK THE COMMUNITY