Question PC turns on but no signal to monitors and PC won’t turn off with power switch

Aug 27, 2022
7
1
15
0
I am new to pc building and I have recently decided to upgrade my prebuilt PC I watched many videos on how to do so correctly but when I had finished putting in the new parts (PSU and GPU) the computer would turn on but all monitors have no signal
The weirdest thing of all is the off switch won’t turn the pc off

Parts
Prime B450M-A
Amd 5 2600
Radeon rx580 (upgrading to a zotac 3060ti amp)
Evga PSU 450 watts (upgrading to a Evga 650)
 
I am new to pc building and I have recently decided to upgrade my prebuilt PC I watched many videos on how to do so correctly but when I had finished putting in the new parts (PSU and GPU) the computer would turn on but all monitors have no signal
The weirdest thing of all is the off switch won’t turn the pc off

Parts
Prime B450M-A
Amd 5 2600
Radeon rx580 (upgrading to a zotac 3060ti amp)
Evga PSU 450 watts (upgrading to a Evga 650)
Psu model? When you upgraded the GPU did you make sure to fully uninstall the old gpu drivers
 
Aug 27, 2022
7
1
15
0
I have someone coming over Tuesday to trouble shoot more I have also received a new mother board, hopefully he’ll be able to replace it
 

MonkeyNoSee

Prominent
Dec 6, 2020
73
6
545
1
I am new to pc building and I have recently decided to upgrade my prebuilt PC I watched many videos on how to do so correctly but when I had finished putting in the new parts (PSU and GPU) the computer would turn on but all monitors have no signal
The weirdest thing of all is the off switch won’t turn the pc off

Parts
Prime B450M-A
Amd 5 2600
Radeon rx580 (upgrading to a zotac 3060ti amp)
Evga PSU 450 watts (upgrading to a Evga 650)
have you tried removing the power cord and revoving the battery to motherboard press power button replace battery plug in try again?
 

ASK THE COMMUNITY