Question PC turns on, but peripherals and monitor don't

Sep 2, 2022
6
0
10
0
Hi, so while i was using my pc, it suddenly froze and nothing i could do, basically the whole pc froze not just the program i was using. So i tried to restart the PC through the button on the case, and that didnt work too so i just switched the pc off. When i turned the pc back on, the rgb and fans were on but my peripherals and monitor didn't receive any signal. There were a lot of ppl who had the some problems throughout a lot of forums so i tried the solvings that they used but nothing worked. Here's the list of things that ive already done:
  • Pressing the power and restart button (not at the same time) for a couple secs while the plug is out
  • Taking out the ram and gpu and reinstalled them
  • Reinstalling the cmos battery
  • Shorted the cmos battery
My pc has been used for around 2 yrs now and i clean the dust frequently. Any idea what might happen to it?

specs:
Windows 10
i5 9400f
Asrock B365 Pro4
Sapphire Nitro+ RX 570 8GB
TForce 2x8gb
Corsair CX550M
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Corsair CX550M
How old is the PSU in your build? If it's as old as your entire build, try and source a donor PSU that has 650W of power at the entire system's disposal.
 
Sep 2, 2022
6
0
10
0
Welcome to the forums, newcomer!

Corsair CX550M
How old is the PSU in your build? If it's as old as your entire build, try and source a donor PSU that has 650W of power at the entire system's disposal.
It's actually has been used for around 1 yr cause i replaced an old one w this one, same model and everything but the old one was faulty. I will try that
 

ASK THE COMMUNITY