Question pc turns on, fans and rgb works, but my mouse an monitor wont show or work

Dec 23, 2020
6
0
10
0
Hi,
when i turn on my pc, it starts working but, dosent show on my monitor and my mouse () wont light up ether but my keyboard will.

my monitor ether stays black or says no signal detected. i have tested both monitor and kabel and bith works fine.

i have tryed 3 f** motherboards, swapted out the old ram whit a new set. diffrent cpu and nothing.

specs:
ryzen 5 5600x
rtx 3080
DDR4 32gb 8gbx4 3600MHz
msi thomahawk x570/ x570 aorus elite
corsair rm 750x
corsair NVMe PCIe GEN4 M.2 SSD
NZXT kraken x53
phantom p600 case

steelseries rival 600
steelseries arctic pro wireless
BENQ zowie xl2756s
ducky one 2 mini
 

Mista Krank

Great
BANNED
Oct 23, 2020
138
1
85
0
This happened to me a couple days ago. Try and unplug the power cable wait for 10-15 seconds then plug it back in. It worked for me and hopefully it works for you.
 

Mista Krank

Great
BANNED
Oct 23, 2020
138
1
85
0
Hi,
when i turn on my pc, it starts working but, dosent show on my monitor and my mouse () wont light up ether but my keyboard will.

my monitor ether stays black or says no signal detected. i have tested both monitor and kabel and bith works fine.

i have tryed 3 f** motherboards, swapted out the old ram whit a new set. diffrent cpu and nothing.

specs:
ryzen 5 5600x
rtx 3080
DDR4 32gb 8gbx4 3600MHz
msi thomahawk x570/ x570 aorus elite
corsair rm 750x
corsair NVMe PCIe GEN4 M.2 SSD
NZXT kraken x53
phantom p600 case

steelseries rival 600
steelseries arctic pro wireless
BENQ zowie xl2756s
ducky one 2 mini
Did it work for you
 

Obiwancanabi

Proper
Dec 24, 2020
124
25
120
3
got the right bios flashed? sounds like a post failure to me, if you changed things out then im assuming ram n things are seated right, bar hardware failure theres not much that would cause it, how many ram sticks you got in? try bare minimum if you got more than 1 just use 1 and try, remove the GPU and try the onboard, just get something to work in some configuration, but what i know the bios needs updating even on the x570's
 
Dec 23, 2020
6
0
10
0
i am prety sure i have the rigth bios flashed, but if i update the bios do i need to take my pc apart first.

i have tried only one ram stick (i have 8gbx4).

thx for the reply
 

Obiwancanabi

Proper
Dec 24, 2020
124
25
120
3
the only thing i havent switched is the psu and case.
could ether of these make this type of problem???
I wouldnt have thought so, unless the PSU isnt kicking out enough power to boot it sounds like its trying, the only thing the case might do is stop the power button from talking to the mobo, i cant see that being your issue. as for the bios flash im unsure to be completely honest, never really had a new enough pc to need to worry about bios flashing lol, i just know they needed flashing to a new bios update or they wont work. if your mobo has a quick flash USB on the back it makes it easier, i dont think you need an older gen CPU to update
 
Reactions: Endre021
Dec 23, 2020
6
0
10
0
i have no tried to update the bios, and it doesent update. by the looks of things, it dosent register the flash-drive. wich would make sense when either the hdmi or usb's dosent give no signal.
 

ASK THE COMMUNITY