Question Pc turns on for a few seconds and turns off repeatedly!

May 20, 2019
2
0
10
0
So recently I just bought a i7-8700k and when I tried to swap out my cpus, my 8700k doesn’t boot up. It just turns on for a few seconds and turns off repeatly. Also the fans and all other stuff turns on but no display and repeats. I tried methods like switching rams, clearing cmos, taking out battery, and updating bios. Nothing has worked. But when I use my i7-8700, it works. So is it just my cpu that’s broken? CPU is in perfect condition. Please let me know what yall think.

Thanks in advance.

Specs

CPU - I7-8700k / i7-8700 (old)

CPU Cooler - EVGA 280 CLC (280x140mm)

Ram - 32GB GSkillz (3000mhz)

Motherboard - Z390 Aorus Master

GPU - Zotac Amp Extreme Edition 1080Ti

SSD - 970 Evo 1tb

HDD - Seagate 1tb

PSU - EVGA 1000w GQ 80+gold

Case - Cougar Conquer
 
The Z390 AORUS MASTER has Onboard LEDs and Buttons
CPU/DRAM/VGA/BOOT (Status LEDs) used for trouble shooting.
During POST (Power on Self Test) they will blink however if any stay lit then you have a problem and the system will not Boot. Do any of these stay lit ?

Did you clear CMOS prior to Bios update and new CPU installation ?
 
Last edited:
May 20, 2019
2
0
10
0
The Z390 AORUS MASTER has Onboard LEDs and Buttons
CPU/DRAM/VGA/BOOT (Status LEDs) used for trouble shooting.
During POST (Power on Self Test) they will blink however if any stay lit then you have a problem and the system will not Boot. Do any of these stay lit ?

Did you clear CMOS prior to Bios update and new CPU installation ?
Theres an orange light for “bios led”
 

ASK THE COMMUNITY