[SOLVED] PC turns on, no display, no peripheral lights, no BIOS/boot and can't turn off.

Apr 29, 2020
1
0
10
0
I built my pc on 2014. Cleaned and cared properly. A week ago it started to freeze randomly while scrolling/gaming, so i rebooted it and it was ok. Some days ago, it started to turn on (fans and lights) but it didn't boot or got into bios. I changed MB/CMOS battery, reinstalled RAM, disconnected drives and nothing happened. No CPU beeps either. Tried changing display cable and port, but it isn't the problem.
Also, when i turn it on i can't turn it off with the power button on case, no even hard reset; i just can pull the plug.

Even with drives disconnected it doesn't do anything.

What can i do? I suspect it's the PSU but i don't have any around to test and also can't afford to buy one and then discover it wasn't.
I'm from Chile so we had some blackouts that maybe did something to it.

Can it be the MB?

Thanks in advance.

CPU: AMD fx 8320
MB: Asus M5A97 LE R2.0
GPU: r9 270x 4gb Sapphire
HDD: 1tb WD and 500gb Seagate
SSD: 120gb WD
Cooling: Corsair WC h60
PSU: Thermaltake smart 550W 80+ bronze
 

R_1

Glorious
Ambassador
Welcome to the forums :D
I think its the PSU too. the only step is to play swapsies with another system. have a friend or sibling or neighbor who has a PC you could swap them PSUs out for three minutes and you will have an answer.

without clean power any tests or diagnostics you run are questionable at best, you cannot test anything without power.
 

R_1

Glorious
Ambassador
Welcome to the forums :D
I think its the PSU too. the only step is to play swapsies with another system. have a friend or sibling or neighbor who has a PC you could swap them PSUs out for three minutes and you will have an answer.

without clean power any tests or diagnostics you run are questionable at best, you cannot test anything without power.
 

ASK THE COMMUNITY

TRENDING THREADS