PC turns on then shuts off after a few seconds.

Jan 14, 2019
1
0
10
0
Hello all.
I've had this computer running for about 3 weeks or so in an older case with no issue. I bought a new case along with a liquid cooler and some case fans. I swapped everything into the new case and hit the power and it shuts off within 5 seconds. After trying what I could in the case, i decided to disassemble everything and hook up the minimum needed, ie mobo, cpu, ram, cooler and psu. I put everything together on the mobo box and made sure all power plugs and ram were seated good, but got the same result. I swapped around the ram in different locations with 1 or both sticks and same result. I reset the cmos and even pulled the battery and you guessed it, same result.now after a few days of racking my head against the wall, I decided to try without ram installed. Now, the computer actually stays on.. So the question is, is it the ram, or mobo?

Here is my system.

CPU: AMD - Ryzen 5 2600 3.4 GHz 6-Core Processor

CPU Cooler: Corsair - H115i PRO 55.4 CFM Liquid CPU Cooler

Motherboard: Gigabyte - B450 AORUS M MicroATX Motherboard

Memory: Corsair - Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 Memory

Storage: PNY - CS900 480 GB 2.5" Solid State Drive

Storage: Western Digital - Caviar Black 1 TB 3.5" 7200RPM Internal Hard Drive

Video Card: PNY - GeForce GTX 1060 3GB 3 GB Video Card

Case: Thermaltake - View 21 Tempered Glass Edition ATX Mid Tower Case

Power Supply: Corsair - RMx (2018) 750 W 80+ Gold Certified Fully-Modular ATX Power Supply

Case Fan: Thermaltake - Riing 12 RGB Triple Pack 40.6 CFM 120mm Fans

Thank you.
 

ASK THE COMMUNITY

TRENDING THREADS