Question PC will not boot to bios / Black screen

Jun 4, 2019
7
0
10
0
Warning Long post

PC specs:

CPU - Ryzen 2600

GPU - Sapphire RX 580 8gb

MOBO - X370 Asus Crosshair VI extreme

RAM - HyperX 16gb 3200mhz

PSU - EVGA G2 1000W Gold

NVME - Intell 660p 1Tb

Hello everyone, my built PC will simply not boot to the bios via my tv.

There is an output signal on the TV, it shows 720p and 50hz. However the screen will then either remain black indefinitely or show stripped multicoloured static.

I've built this first PC almost 2 months ago where I ran into the exact same issue with a previous RX 580. I thought that prehaps its the GPU and as such returned it, buying from another source.

Having received a new rx580 today it seems the same issue still persists. Meaning it can't be a gpu fault.

Every component that has Led, RGB or a fan clearly turns on.

I know that the x370 and ryzen 2600 are only compatible with a bios update. I bought the mobo from a seller who clearly showed that the mobo had the newest bios. The Crosshair VI extreme can already support ryzen 2000 series out of the box. Once again I dont see an issue there.

WHAT TROUBLESHOOTING HAVE I DONE:

- I've already taken the whole system out of the case including re-installing all the components.

- Used both HDMI ports on the GPU as well as the two ports on the tv itself. (Unable to test Display port)

- I have two 8Gb RAM sticks, I've tried every possible combination on the dimm slots. Including both sticks, singular stick as well as looking at the Mobo manual.

- Switched the GPU to all 3 available PCIE slots, double checking to see if its mounted properly.

- Tested both the tv and HDMI cable used with a PS4 that works completely.


The only conclusion I can come up with is

- The Mobo is broken some how

- The ryzen 2600 is broken

- I need a Ryzen 1000 series and see if it'll boot then.


Any other suggestions are welcomed. Thank you
 
Jun 4, 2019
7
0
10
0
How did the vendor show you the bios was updated? Do you see any diagnostic LED's lit on the motherboard? If so look them up via the motherboard's manual.

Great questions Scream

In terms of the vendor, they showed a screenshot of the bios with the latest firware at the time.

In terms of the LEDs, theres one green lit up on BOOT.

The Q code is also showing A9 which according to the manual means start of setup.
 
Jun 4, 2019
7
0
10
0
Please post the screen shot of the bios that they provided, on the forum.
Just now I used ASUS bios usb flashback feature on the mobo.

I followed all the steps required to format the usb as well as set up the bios update. It completed on the mobo.

To my disappointment the issue is still persisting.

I installed version 7106 bios (latest as of today)
 

ASK THE COMMUNITY

TRENDING THREADS