Question PC will not boot with an external drive plugged in

Jan 13, 2020
5
0
10
0
So I have been having this issue where my PC will not complete the boot process and and the VGA light on the motherboard illuminates and I get a black screen. I made a previous post on this forum that goes into more detail about the issue, but after weeks of trouble shooting, I have found the cause. After owning the PC for about 6 months I purchased an external hard drive (WD 2TB HDD) and made the connection in my mind that this is roughly when the issue started to occur. Whenever the drive is disconnected from the case or motherboard, the machine boots up fine. When connected, I get a EZ-Debug light and a black screen. The simple solution is to not boot the machine with the drive connected, but I do not want that. I want it to boot with it connected. So I have tried to reformat the drive, change the boot order in the BIOS, BIOS updates, but still no luck. Any suggestions on how I could resolve this issue? Any help will be appreciated!!

Specs:
Ryzen 5 2600
MSI B450 Tomahawk
Corsair Vengeance RGB pro 16gb
Gigabyte RX 580 8 gb
EVGA 650w 80+ Gold
 

Ralston18

Titan
Moderator
More information needed.

And you mention "case or motherboard" - did you mount the drive in a third party external USB case?

Does the case have its' own power supply?

Which specific WD 2TB HDD did you purchase?
 
Jan 13, 2020
5
0
10
0
More information needed.

And you mention "case or motherboard" - did you mount the drive in a third party external USB case?

Does the case have its' own power supply?

Which specific WD 2TB HDD did you purchase?
I plugged it into the rear usb ports as well as the two usb ports on the front of my NZXT H500 case which connect to the motherboard. The hard drive is just a 2TB My Passport hard drive by Western Digital
 

ASK THE COMMUNITY

TRENDING THREADS