Question PC will not enter POST, possible motherboard failure?

JJnaron

Honorable
Nov 22, 2013
25
0
10,530
0
Specs:
Mobo: Asrock Fatal1ty Z87 Killer
CPU: Intel i5 4670k
GPU: Gigabyte GTX 760
PSU: OCZ ZT 650 watt
RAM: 2x 4gb GSkill Ripjaws X
HDD: Seagate 1tb
OS: Windows 7

So this is my dad's pc I built for him a few years ago, and recently my dad tried turning his PC on for the day and it would power up, but no video, no keyboard, and no mouse. The PC will run fine, all fans running, all components running, but there's no way to get it past POST. When it starts up there's no beeps, no flickers on the screen, no lights on the keyboard/mouse, nothing. My dad tells me it's been doing this for a while but if he would turn it off and on enough eventually it would start up.

So here's what I've tried. I've taken the whole PC apart and cleaned it with compressed air, cleaned all the connectors, and put it back together.
I tried running it on the bare essentials (No GPU, nothing plugged into the USB, no case fans, no disc drive) and I got the same result. I tried removing the CMOS battery, that didn't change anything either. I unplugged the pc and held the power button for 30 seconds, nothing. I took the RAM out of my own PC and installed it in his (2x 4gb ram cards) still nothing. I also tried his RAM in my pc and it did fine.

Here's something I noticed while messing with the RAM. If i put the 2 cards in ANY other slots than were they were originally (Mobo has 4 slots, the ram cards were originally in the 2 & 4 slots) the pc will power on like it does, but will shut off after about 7-10 seconds. Then it'll power right back on and the process repeats itself over and over. Just power switching endlessly. But it doesn't do this when the cards are in the 2 & 4 slots.

When the PC is running I can feel the CPU heatsink getting warm, so I don't think the CPU is dead. Every other component on the PC runs fine from what I can tell.

So at first I thought maybe the PSU was failing and wasn't sending enough power to the mobo to get it to POST. So we ordered a new PSU (EVGA 650GX) and installed it. Same issue. So we'll be sending that back.

I'm almost positive the motherboard is failing/failed. But before I order a new one for him I want to hear what everyone else thinks about it and maybe can suggest some more tests for me to try. I've gone through a similar thing with my PC where I thought the mobo was fried (PC wouldn't POST, like my dad's) but all I did was take it all apart and clean it and somehow it worked itself out. It's been running fine for 6 months now. Also me and my dad built our PCs at the same time around 2015, to give you an idea of how old the components are.

There's no obvious signs of failure on the motherboard either. I don't notice any blown capacitors or fried components.

So what do y'all think, is it most likely a fried motherboard or are there some other things I haven't tried? Anyone been through a similar issue where it wasn't the mobo?
Also we'll most likely just replace the mobo with another one like it, which is hard to do because they don't make them anymore.
 
Nov 5, 2018
3
1
15
0
Assuming the CPU isn't overheating or massively overclocked I'd say it is a pretty safe assumption that it's the motherboard. If you haven't tried one stick of ram at a time, I'd do that. See if one works and one fails. If that doesn't do anything different and you haven't removed the CPU recently then it's almost certainly the motherboard. It could be the CPU but CPUs failing are extremely rare without over volting the bejesus out of them or roasting them with a bad AIO or a tiny dust filled heatsink.
 

ASK THE COMMUNITY

TRENDING THREADS