Question PC(wired connection) having buffering/lower quality on youtube/netflix

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
Some more information:
This problem started after an internet outage Wednesday night (6/15/22)
I have had the same pc hardware/setup for nearly two years at this location
I have no problem watching twitch streams
I have tested my internet for speed and packet loss(there is no packet loss)
I have called Verizon and they found no problems with speed or packet loss on their end
I have a PS4 that is connected wirelessly with no issues loading content from Youtube/Netflix
I have cleared my cache on google chrome
I have the same issue when using Microsoft edge

PC Specs (if that matters)
Windows 10 Home
AMD Ryzan 7 1800X
16gb G-skill RAM
Gigabyte GTX 1080

Thanks in advance for any help, this has been incredibly frustrating as I use my pc for media consumption much more than my PS4 connected to my TV.
 
Jun 19, 2022
7
0
10
0
made an account just to say the exact same problem is happening to me, complete with the Wednesday night outage right before it. PC connected to ethernet can't load a full 144p YouTube video, laptop connected with 1 bar of wi-fi can run them seamlessly at 1080p. Twitch and speed tests also check out fine. I think I also had this problem once or twice before a while ago. within the last year or so. On verizon fios
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
made an account just to say the exact same problem is happening to me, complete with the Wednesday night outage right before it. PC connected to ethernet can't load a full 144p YouTube video, laptop connected with 1 bar of wi-fi can run them seamlessly at 1080p. Twitch and speed tests also check out fine. I think I also had this problem once or twice before a while ago. within the last year or so. On verizon fios
you wouldn't happen to be in Maryland would you?
 
Jun 19, 2022
7
0
10
0
I'm in columbia. this makes me wonder if it could be an ISP issue despite all of my testing pointing to a software issue on my PC.
I downloaded a vpn called proton on my pc, has some free servers in the us and I think only streaming services require a plus subscription. it has no ads and operates under swedish data protection laws or something. youtube is now working normally with it active, on a new york server my download and upload speeds seem to be around 10 mbps lower with about 10 higher ping but it's better than having to open a proxy anytime i want to watch a youtube video for more than 5 seconds per minute at 144p lol. going to be able to test tomorrow if this issue is affecting all ethernet connected computers in the house or just mine
youtube has only been working for me if i use it on a proxy or with a vpn so my ip is changed, i don't know anything about computers or internet but that seems like an important detail
 
Last edited:

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
I downloaded a vpn called proton on my pc, has some free servers in the us and I think only streaming services require a plus subscription. it has no ads and operates under swedish data protection laws or something. youtube is now working normally with it active, on a new york server my download and upload speeds seem to be around 10 mbps lower with about 10 higher ping but it's better than having to open a proxy anytime i want to watch a youtube video for more than 5 seconds per minute at 144p lol. going to be able to test tomorrow if this issue is affecting all ethernet connected computers in the house or just mine
youtube has only been working for me if i use it on a proxy or with a vpn so my ip is changed, i don't know anything about computers or internet but that seems like an important detail
That's really interesting, i found a workaround but it wasn't full proof. I was loading the videos i wanted to watch from youtube in VLC media player but it didn't work on every video.

I talked to the Network admin guy at my work and he suggested trying to reset the ip stack. I'm going to try that when i get home today.
 
I would suspect a browser issue but I suppose it could also be some other software in your machine.

Both twitch and youtube by defualt run over standard HTTPS sessions. From things outside..ie the ISP.. they look like any other encrypted web session except they stay open for a long time and have more traffic. They could limit by ip address but this would affect all your machines.

Could it be one of the adblockers. I know that twitch does everything they can to try to force their ads past ad blockers.

You could boot a USB linux image but if it works that would just verify that you had something strange in windows someplace. It is unlikely hardware since that would affect all types of video. Maybe the firewall or virus software so I guess you could try to disable that.
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
I would suspect a browser issue but I suppose it could also be some other software in your machine.

Both twitch and youtube by defualt run over standard HTTPS sessions. From things outside..ie the ISP.. they look like any other encrypted web session except they stay open for a long time and have more traffic. They could limit by ip address but this would affect all your machines.

Could it be one of the adblockers. I know that twitch does everything they can to try to force their ads past ad blockers.

You could boot a USB linux image but if it works that would just verify that you had something strange in windows someplace. It is unlikely hardware since that would affect all types of video. Maybe the firewall or virus software so I guess you could try to disable that.
I've tried 3 different browsers and disabled all extensions, including ad blockers. I don't have any extra antivirus software, only windows defender and i have not touched any firewall or port settings.
 
Jun 19, 2022
7
0
10
0
That's really interesting, i found a workaround but it wasn't full proof. I was loading the videos i wanted to watch from youtube in VLC media player but it didn't work on every video.

I talked to the Network admin guy at my work and he suggested trying to reset the ip stack. I'm going to try that when i get home today.
Just tried this; I reset ip stack in console, restarted my computer, clicked a youtube video and was greeted once again by a 144p buffering video player
Guess I'm sticking with a vpn for now
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
Just tried this; I reset ip stack in console, restarted my computer, clicked a youtube video and was greeted once again by a 144p buffering video player
Guess I'm sticking with a vpn for now
Yup, just tried it myself and it didn't work for me either. I'm now using you're vpn workaround and its working flawlessly. Might call verizon tomorrow and see what they say.
 
Jun 19, 2022
7
0
10
0
Yup, just tried it myself and it didn't work for me either. I'm now using you're vpn workaround and its working flawlessly. Might call verizon tomorrow and see what they say.
a bit late but just tested youtube on a different ethernet connected pc in the same house, and it was running fine on that pc. I thought maybe the issue was passed or something so i disabled the vpn on my own pc and tried loading youtube, and nope it's still buffering like before, and the apple music web player also wouldn't load. re-enabled the vpn and both sites are working normally again. so it's somehow device specific it seems, but also happened to both of us at the same time in the same area
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
a bit late but just tested youtube on a different ethernet connected pc in the same house, and it was running fine on that pc. I thought maybe the issue was passed or something so i disabled the vpn on my own pc and tried loading youtube, and nope it's still buffering like before, and the apple music web player also wouldn't load. re-enabled the vpn and both sites are working normally again. so it's somehow device specific it seems, but also happened to both of us at the same time in the same area
I'm honestly wondering if a windows update messed something up.

I'm considering getting a copy of windows 11 and updating. I don't really feel like backing everything up and doing a fresh install of 10.
 
Jun 19, 2022
7
0
10
0
I'm honestly wondering if a windows update messed something up.

I'm considering getting a copy of windows 11 and updating. I don't really feel like backing everything up and doing a fresh install of 10.
I switched off the VPN to download something at around 8 AM this morning, and then forgot to turn it back on, but youtube and apple music were still loading normally. Tried again now and everything is still working normally without vpn. So I guess sometime in the last 24 hours the issue fixed itself for me
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
I switched off the VPN to download something at around 8 AM this morning, and then forgot to turn it back on, but youtube and apple music were still loading normally. Tried again now and everything is still working normally without vpn. So I guess sometime in the last 24 hours the issue fixed itself for me
That's fantastic news! Fingeres crossed hoping it stays that way for you. I'll check and see if mines working when i get home in about an hour.
 
Jun 19, 2022
7
0
10
0
That's fantastic news! Fingeres crossed hoping it stays that way for you. I'll check and see if mines working when i get home in about an hour.
I jinxed it lol, it got regressively worse after I sent the last message, it started out just loading a little slow, then the webpage couldnt load, now it's as bad as it was before except now the video player itself can rarely even load
 
Jul 2, 2022
1
0
10
0
Having same issues here, also on Windows 10 / Verizon Fios

My first immediate thought was throttling , especially for commonly large bandwidth sites like youtube, but the odd part is that this isn't an issue on wireless devices...
I confirmed on my linux and mac machines that speeds were fine on sites, both on a wireless connection. The wired windows machine has very fast speeds and network info looks clean so I'm not sure what it is. Other streaming sites like twitch don't seem to have the problem. Hearing that this isn't an issue using a VPN is interesting and even more bewildering.... Not sure what to think or how to fix. Maybe I'll try a VPN or getting a new IP for the house

In case it's relevant or helpful to anyone else the windows version:

Edition Windows 10 Home
Version 21H2
Installed on ‎2/‎21/‎2022
OS build 19044.1766
Experience Windows Feature Experience Pack 120.2212.4180.0
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
I jinxed it lol, it got regressively worse after I sent the last message, it started out just loading a little slow, then the webpage couldnt load, now it's as bad as it was before except now the video player itself can rarely even load
Mine started working properly again without a vpn the other day. I didn't change anything. It just randomly started working.
 

mikbar

Distinguished
Nov 16, 2014
32
0
18,530
0
Having same issues here, also on Windows 10 / Verizon Fios

My first immediate thought was throttling , especially for commonly large bandwidth sites like youtube, but the odd part is that this isn't an issue on wireless devices...
I confirmed on my linux and mac machines that speeds were fine on sites, both on a wireless connection. The wired windows machine has very fast speeds and network info looks clean so I'm not sure what it is. Other streaming sites like twitch don't seem to have the problem. Hearing that this isn't an issue using a VPN is interesting and even more bewildering.... Not sure what to think or how to fix. Maybe I'll try a VPN or getting a new IP for the house

In case it's relevant or helpful to anyone else the windows version:

Edition Windows 10 Home
Version 21H2
Installed on ‎2/‎21/‎2022
OS build 19044.1766
Experience Windows Feature Experience Pack 120.2212.4180.0
Best of luck. I gave up a while ago but it randomly started working properly again the other day and I hadn't changed anything.
 

ASK THE COMMUNITY