Question PC with Asus mobo with multiple problems/questions (Wifi disconnects + Mouse/Keyboard lag)

londy123

Commendable
Feb 22, 2018
1
0
1,510
0
Hi everybody!

Two years ago I "built" a pc (I choose the parts and I paid the store to check components compatibility and built it) with the following parts:

  • ASUS B250-PRO
  • Intel Core i7-7700
  • Crucial DDR 2400 PC4-1922 8GB CL17 (x2)
  • Samsung 960 EVO NVMe M.2 SSD PCI-e 250GB
  • Asus Dual GTX 1060 OC 6 GB GDDR5
  • TP-LINK-WN881ND 300Mbs 11n Wireless PCI Express Ver 2.0
  • Seasonic S12ii 620 80 Plus Bronze
I have 3 questions/problems and I need your help. It would be great if you could help me.

First of all, I have a question regarding the position of the SSD disk. I have checked the user manuals of the motherboard,

https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/PRIME_B250-PRO/E12110_PRIME_B250-PRO_UM_web.pdf ,

and the fastest M2 socket, it is labeled "M2_2". But the store placed the SSD disk in the M2_1 socket. Why would they do that if the other socket is faster? I am missing something? Also, they place the wifi card to the PCIEX1_1 and the GPU to the PCIEX16_1.

Should I change the SSD to the M2_2 socket?

The next problem is with the wifi connection. Very often the computer loses it. The router is good because other devices are connected to it without problems. I have updated the drivers and even the store sent me a new card, but the problem persists. I kind of let it go because I started using an ethernet cable, but I would like to be able to solve this problem.

Finally, my bluetooth mouse and keyboard recently started to have lag. It is not all the time but they suddenly start to malfunction for a couple of minutes. I have checked CPU and RAM usage and they are far below of being stressed. I switched USB ports, updated USB drivers, reinstalled drivers, check RAM malfunctions with Microsoft memory diagnostic tool, I tried another mouse and keyboard, I used DISM.ese and sfc /scannow, key filters off... and nothing.

What could it be? Should I restore windows or maybe the problem is related to the hardware? Maybe the motherboard? Both problems could be related?

Thank you very much!
 

ASK THE COMMUNITY