Question PC won’t boot after touching Ryzen Master

Oct 19, 2020
1
0
10
0
My game, Rainbow Six Siege, kept crashing after trying everything so I went into Ryzen Master and tapped Game Mode (not knowing its for ThreadRipper) and applied and nothing happened. I hit apply again then it asked me are you sure and I pressed no because I didn’t want to mess with something I didn’t know about. Then I clicked profile 1 and 2 and current to see what the differences were out of curiosity but didn’t apply anything. I exited out of Ryzen Master and moved on. Then I restarted to see if that would help my game from crashing to which the pc never actually started up again.
Now whenever i hit the power button the fans spin for 1 second then turn off.
(Note: the fans only spin when the power supply is on)
I tried shorting the CMOS with a screwdiver and nothing. I took out the battery and shorted again. And then again but longer. Nothing worked. Currently I am letting it sit for a couple hours to 100% discharge but I have a feeling nothing with change which i hope is not the case is there anything else I can try to do? Before it’s confirmed a hardware failure? Also what would have failed? The cpu? Or ram?
I would think if the fans power on then the motherboard is good but I don’t know.
CPU: Ryzen 3 2200G
RAM: Ripjaws V 8GB 3200 (2x4 GB)
Motherboard: AsRock B450M Pro4
 

ASK THE COMMUNITY

TRENDING THREADS