Question Pc won’t power everything seems to be fine

Oct 11, 2020
3
0
10
0
Pc has been fine since i upgraded in august.
Specs
gtx 1660 super
Ryzen 7 2700x
32gb 3200mhz ddr4 ram
asus rog strix B450-F mobo
kolink 850w power supply
250gb m.2
2tb hdd
9x fans

was working fine then came on this morning clicked the power on button and the fans spun for a quarter of a second, rgb on the motherboard was working. thinking it could possibly be my psu i switched it with a corsair 450w one, but again no success. making sure both psu was 100% working i tried both on my other pc and they was both working fine. did research and tried i think everything, removed cmos method, 1 stick of ram and no gpu method and more. could this be a motherboard problem? it’s my newest part i haven’t done anything that could’ve messed it up. i have cable extenders for the cpu gpu and 24pin power cable but don’t see why that would affect it, stuck with what to do. please help
 
Oct 11, 2020
3
0
10
0
"could this be a motherboard problem? it’s my newest part..." Being the newest part, I would suspect a faulty mobo from the factory. RMA it.

thanks for the reply, i have just been messing with it a bit, i have found out that when i have just the 24pin plugged in by its self it seems to work, after that i turned it off and then proceeded to try stuff adding it once at a time to find out what could possibly be happening. upon plugging the cpu it takes me back to my original problem everything works par the cpu any suggestions on what i should do from here?
 

ASK THE COMMUNITY

TRENDING THREADS