Jun 11, 2021
1
0
10
0
Hi! First time poster here and I’m desperate. Let’s start with the specs:

-16GB of RAM (T-Force brand)
-GTX GEFORCE 1660 GPU
-AMD Ryzen 7 3700
-BF 450 ASUS Motherboard
-Not sure about the PSU, honestly. Might be an Azza 650W
This is a custom pc built around August 2020 with brand new parts. However it has this very annoying, weird and wildly inconvenient problem which is that, sometimes, when I shut it down, it doesn’t turn back on. This mostly happens when we get our power shut off because of storms. However, since I have a backup battery I can always make sure to shut it down properly instead of letting the power surge turn it off abruptly. Here are the circumstances in which we have gotten my computer to turn back on after these incidents

-Once we disconnected all the ports of the motherboard, the RAM, the GPU and CPU, then connected them back again for it to spurt back to life.
-We took it to a computer technicians house and connected it there, only for it to turn on normally despite us trying countless times in my own house. This has happened multiple times.
-We took the PC tower for a 30 minutes ride away from my house, brought it back to my room and it turned on normally.

Thanks to this happening almost every time we loose power, we have made it a routine to do these in a check list format until we reach the last option: take it to the computer technicians house. The problem is, when we do take it there, he can’t do anything about it because the computer behaves normally. So we essentially pay someone to let us plug in my computer at their house lmao.

We have checked all the components of my PC and even when it doesn’t turn on, the LED of the GPU is on and you can hear the light buzz of electricity running through the computer. It just..doesn’t boot up. Like it just gets stuck at that part.

Other than that, the computer functions perfectly fine when it is on! I would appreciate any help as I’m a digital artist and streamer and use my computer for everything. Me and my brothers have speculated everything from a faulty PSU to the electromagnetic fields screwing up the energy haha, but essentially, we know nothing. Thank you for reading this and apologies for the format. I’m in mobile.

(NOTE: My computer was the only one this happened to, but my brother’s computer has recently encountered a similar problem. HOWEVER, other household computers don’t. And yes, I have tried different outlets)

EDIT: here is a list of things I’ve tried and have not worked.
-Reseated RAM and GPU (separately and together)
-Held power button for different variations of times
-Took out the CMOS battery for 15 seconds
-Shook the damn thing lmao
-Disconnected all the ports in the MOBO and reconnected them
-Let it sit for a day disconnected
-Let it sit for a day connected and, technically, turned on
-Other things mentioned above that worked once, but have not worked again (taking it out to drive, disconnected EVERYTHING, etc.)
 
Last edited:
Jun 11, 2021
9
1
15
0
I dont really have an explanation.. BUT I seen it before... my best guess its a protection circuit in the power supply... mine, if I unplugged the cord for few minutes and plugged it back in it turned back on.... replacing power supply fixed the problem
 

ASK THE COMMUNITY