Question PC won't boot after adding RAM

Jan 7, 2020
3
0
10
0
My Fujitsu Esprimo P2560 is beeping and won't boot after RAM upgrade. When power on, it just beep with like this: * * * (about 100bpm speed) and then stops. The fans are at full spin, the screen doesn't wake up. The new RAM stick (corsair 4gb 1333mhz) is the same with the current stick that came with the pc. I tried to turn it on with the new stick only (in both slots), I blew the slots to remove the dust, I made a CMOS reset by removing the battery but none of the above could make my pc boot. As I know, my pc is capable ro up to 8gb RAM memory DDR3 1333mhz.
Not that my BIOS settings does not include memory adjustments like voltage or clock speed.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Just to be sure, do you have any BIOS updates pending for that prebuilt system? The data sheet does state that the system can go to a max of 8GB of DDR3-1333MHz ram.

Here's something you could do, if it has a discrete GPU on the prebuilt, remove it and see if you get the system to boot. Also, did you modify anything else on the system apart from the ram?
 
Jan 7, 2020
3
0
10
0
Welcome to the forums, newcomer!

Just to be sure, do you have any BIOS updates pending for that prebuilt system? The data sheet does state that the system can go to a max of 8GB of DDR3-1333MHz ram.

Here's something you could do, if it has a discrete GPU on the prebuilt, remove it and see if you get the system to boot. Also, did you modify anything else on the system apart from the ram?
Thank you for the quick response.

Yes, I've changed the graphic card to 2gb.
I will try what you suggested and I'll let you know.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts