Question PC won't boot after shutting it down from the other night

Jul 8, 2019
31
0
30
0
Forgive me if this isn't the right forum, i couldn't find anything "tech support" as an option.

Second time that it has happened. So basically when I do manage to boot it, it works fine with alot of hours of usage. After shutting it down and going to bed, the next day, it would have a hard time booting. The usual errors are ntfs.sys and ntoskrnl.exe.

I tried removing some peripherals and rebooting the PC, ultimately successfully booted after removing the mouse from the USB drive, connect it after it boots and it's good to use.

Are there any steps I could try to see what problems I have? Windows are completely up to date, drivers are all up to date. It's a brand new build, around 2 weeks too.

Specs are;
Ryzen 3 2200g
Asus B450m-a Prime
2x8GB Corsair Vengeance 2133mhz
RX570 Sapphire Nitro 8GB
Corsair VS450 PSU.

From experience, it seems to have a hard time booting properly after resting. Memtest86 and windows diagnostics shows no problem with the RAM.
 

InvalidError

Titan
Moderator
Nearly every time I have had a PC that randomly struggles to boot, it has been due to a dying output capacitors in the PSU. The Corsair VS450 has low quality (mostly CapXon) output capacitors, so I'd be inclined to suspect those if the PSU is over two years old.
 
Jul 8, 2019
31
0
30
0
Nearly every time I have had a PC that randomly struggles to boot, it has been due to a dying output capacitors in the PSU. The Corsair VS450 has low quality (mostly CapXon) output capacitors, so I'd be inclined to suspect those if the PSU is over two years old.
Everything's brand new less than a month old. Is there a way I can test this out or do I have to go and test / get another PSU.
 
Aug 15, 2019
14
3
15
0
Disconnect every connection from the PSU and short the Green and Black pins on the PSU's motherboard power connector and then turn on the PSU. The PSU fan should work and the LEDs if any would come on. If it isn't, your PSU most likely died, says my hardware repairing friend.

OFFTOPIC:
I had my Seasonic G550 Gold PSU died just like OP's recently!
May be tis the season of failing PSUs lol:D
 
Reactions: rigg42
Jul 8, 2019
31
0
30
0
Disconnect every connection from the PSU and short the Green and Black pins on the PSU's motherboard power connector and then turn on the PSU. The PSU fan should work and the LEDs if any would come on. If it isn't, your PSU most likely died, says my hardware repairing friend.

OFFTOPIC:
I had my Seasonic G550 Gold PSU died just like OP's recently!
May be tis the season of failing PSUs lol:D
By the way, is it still possibly a failing PSU when it works perfectly fine IF I don't shut it down at all?
 

InvalidError

Titan
Moderator
By the way, is it still possibly a failing PSU when it works perfectly fine IF I don't shut it down at all?
Yes, there are a few different possible reasons. At power-up, most hardware is in its uninitialized state where it is usually off and poses a completely different transient load scenario from normal operation, the PSU may be fine under normal load but be struggling to remain within specs under extremely light load. A bad solder joint while the PSU is cold may be causing trouble and "come good" once the PSU has warmed up until the PSU cools down again. An intermittent fault in the 5VSB supply may get overridden by the main converter once you get lucky enough for the PSU to enter normal operation. I'm sure there are a few more possibilities, these three categories cover all of the PSU-related repairs I remember doing.

In all three cases, the main symptom is randomly failing/succeeding to turn on.
 
Jul 8, 2019
31
0
30
0
Yes, there are a few different possible reasons. At power-up, most hardware is in its uninitialized state where it is usually off and poses a completely different transient load scenario from normal operation, the PSU may be fine under normal load but be struggling to remain within specs under extremely light load. A bad solder joint while the PSU is cold may be causing trouble and "come good" once the PSU has warmed up until the PSU cools down again. An intermittent fault in the 5VSB supply may get overridden by the main converter once you get lucky enough for the PSU to enter normal operation. I'm sure there are a few more possibilities, these three categories cover all of the PSU-related repairs I remember doing.

In all three cases, the main symptom is randomly failing/succeeding to turn on.
Besides what the other dude said, what do tests or what do you suggest I do? Maybe there are steps I could do to figure it out before going out and replacing the PSU. The warmup part does make sense, apparently it didn't matter which was connected or wasn't, it's just after a good 10-20minutes of turning it on and off and on or letting it loop itself, until it finally worked.
 

InvalidError

Titan
Moderator
The simplest test would be to simply swap out the PSU if you have any other PC with a decent appropriate size PSU you can borrow. If you are still within the return window, you could get it exchanged. Otherwise, RMA may also be an option.

Swapping other components to troubleshoot the PSU sounds silly to me and only exposes more hardware to possible damage by a faulty PSU. The ideal way to call out a bad PSU would be to connect every output to an oscilloscope to see exactly what happened just before the PSU shut off. Missing output rail? Excessive ripple? Voltage out of spec? Too slow ramp time? Loss of PW_ON# signal? Loss of PW_GOOD# signal? Etc.
 

ASK THE COMMUNITY