Question PC won't boot after turning on secure boot

Sep 5, 2021
2
0
10
0
Hello guys,

recently I've swapped to WINDOWS 11 to try it out. Everything was working just fine but after a few days Vanguard from Valorant kept giving me error for not having TPM 2.0 and Secure boot enabled. TPM was enabled but SB was not so I went to BIOS to enable it and after restart nothing was working. The screen is black, USB's don't work only MB RGB lights are on (they even keep running after turning off PC), CPU and SYS fans work but nothing is happening. Sometimes I can't even turn the PC off with button.

I've tried clearing CMOS, disconnecting everything even turning PC on without button connected but nothing has worked and since I can't get to BIOS or WIN I can't think of anything else. GPU is working, HDMI's are fine and displays aswell. Changing RAM's does not help either.

DRAM, CPU and VGA LED's on MB are flashing slowly.

Thank you for every suggestion.

PC SPEC

AMD Ryzen 5 5600x
Gigabyte B550 Aorus PRO ac
HyperX Predator 3200 MHz 2x8 GB
Sapphire RX 480 4GB
beQuiet! Pure Base 500DX
WD SN850 1TB
Corsair RM750 2019
 
Sep 5, 2021
2
0
10
0

Colif

Win 10 Master
Moderator
I am hoping the release version of win 11 doesn't want me to turn secure boot on as right now the test on their site says I pass everything else, and I am running 11 now.

A bit worrying some Gigabyte bios do this.
 

COLGeek

Cybernaut
Moderator
Looks like same issue here, as well.


I have a similar test rig and will take a look on my end.
 

COLGeek

Cybernaut
Moderator
I enabled Secure Boot on my Win 11 (B550) and two Win 10 rigs (both with X570) today. Nothing unusual at all afterward.

Steps to enable (all AMD-based Gigabyte mobos) Secure Boot. Make sure fTPM is enabled. Make sure CSM is disabled. In Secure Boot, select custom under Secure Boot Mode, Select Restore Factory Keys, Say YES to reset without saving.

When BIOS restarts, access BIOS and change Secure Boot Mode back to Standard and then Yes to restart without save.

Let Windows boot fully.

Use msinfo to verify that Secure Boot State is on.
 

COLGeek

Cybernaut
Moderator
I can confirm that Valorant "killed" my primary display. Fortunately, I have two displays attached to my Win 11 beta rig, where I uninstalled Valorant.

Removing game seems to resolve the matter.
 

Colif

Win 10 Master
Moderator
I enabled Secure Boot on my Win 11 (B550) and two Win 10 rigs (both with X570) today. Nothing unusual at all afterward.

Steps to enable (all AMD-based Gigabyte mobos) Secure Boot. Make sure fTPM is enabled. Make sure CSM is disabled. In Secure Boot, select custom under Secure Boot Mode, Select Restore Factory Keys, Say YES to reset without saving.

When BIOS restarts, access BIOS and change Secure Boot Mode back to Standard and then Yes to restart without save.

Let Windows boot fully.

Use msinfo to verify that Secure Boot State is on.
I have bookmarked this post so if I need to turn it on to use win 11, I will look at this. right now, beta doesn't mind and test says I pass so I leave it as is.

Its not valorant, its the anti cheat program that you have to run to use it. It runs at ring 0 of the CPU, same access as Kernel. It thinks it owns any PC you install it on. If it wasn't needed to play game I would call it malware.
vgk.sys
 

ASK THE COMMUNITY

TRENDING THREADS