[SOLVED] Pc wont boot after upgrading cpu

Jan 18, 2022

today I decided to upgrade from ryzen 5 3500x to ryzen 7 5800x. My motherboard, b550m pro4 supports the 5800x but only with an older version of bios 1.20, it says so here:

https://www.asrock.com/mb/AMD/B550M Pro4/index.asp#CPU

So i installed the version 1.20 of bios successfully and went on to replace the cpu. When all was done, turned on the pc and i got into windows. After a few seconds I realized I forgot to reset bios settings to default when I installed the older version of bios. So I restarted my pc and did so, i also set the xmp correct settings for ram. After i saved and rebooted the pc, there was no display, just a black screen with pc running. I realized the pc fans kept spinning faster than usual and there was nothing turning up on the monitor. After a couple more restarts, I realized the dram and cpu leds are on.

What I’ve tried:
-Reinstalling ram, one by one.
-Changing back the r5 3500x cpu
-Reseting cmos.

All with the same result even after trying the previous cpu that was working. Note that first boot with the new cpu was succesful, only after reseting bios settings the pc wouldn’t boot anymore.

I have had the pc for a year now and it was running fine.

Anyone might know any other tips? Do you guys think both my cpus are dead? Or is it just the motherboard? Any help is much appreciated.

my pc specs:
CPU: Ryzen 5 3500x
MBO: Asrock B550m pro4
RAM: 2x DDR4 Hyperx fury 8gb 3200 MHz
GPU: Asrock Rx 5600 xt oc phantom gaming
PSU Evga 650W
Last edited:
the info in the link doesn't mean that you should downgrade to 1.20.
it means you need to have at least 1.20.
if you get it running you should be updating to the latest available again.
Do you guys think both my cpus are dead? Or is it just the motherboard?
i would lean more towards an issue with the motherboard.
if you have a spare CMOS battery around try that but i doubt this board is old enough to have drained the original yet.

you may have to troubleshoot each component individually.
finding another similar system to swap components with is the easiest option.
there was no display, just a black screen with pc running
disconnect the GPU cable from the monitor and power the monitor on; do you get "No Signal" message or the same blank/black screen?
  1. if "No Signal", then the system is providing a signal when connected or you would see the same message.
  2. if same blank/black screen, then more than likely your GPU isn't providing any signal to the display.
1 would lead me to testing another GPU in the system.
2 definitely means a deeper problem.

you can always take it to a local shop and see what they'll charge for testing.
but in your situation i would rather troubleshoot what i could myself before resorting to anything like that.
Reactions: al0e
Jan 18, 2022
Hello guys, sorry for not posting an update, these past few days have been a little hectic. I appreciate your advices very much!!!!

Gpu was fine, I did try both ram sticks, and each one individually in each slot, tried booting without a drive.

After writing this post I was browsing a little more and found out that, yeah, I didnt need to rollback bios update. That 1.20 is the least needed version, I feel incredibly stupid.

I ended up going with my pc to a local repair shop, after troubleshooting they found out that my motherboard died. They didn’t know how though, and I’m still wondering.

I do think I know what caused the pc no display and undetected cpu led. I think it was turning on the xmp profile for ram, the guys at the repair shot said the same. I even found some reddit posts about people saying they had the same issue with my new motherboard. They had to reset bios settings through cmos. The problem was fixed with updated bios version.

I still have no clue what caused the motherboard to die after though.