Question PC won't boot, no monitor signal ?

SwagimirPutin

Honorable
Jul 11, 2015
3
0
10,510
0
Hello everyone. This problem appeared a week ago. Sooo... I turned my PC on and monitor says that there's no signal. I had same problem few years ago. Solution was simply removing my GPU and than installing it back.

This time it's far more complicated, so far i tested my gpu in friend's pc, it worked fine so gpu is not s problem. By reading some similar posts here I assumed that cpu or mobo might be faulty, since none of my friends have 1151 intel socket i couldn't test cpu, so i brought all together mobo, cpu and one stick of ram to local IT dude, he "fixed it". He told me something like "some pins oxidated on motherboard, i am not sure what that means.

However problem is not solved after installing mobo back into my pc. Some people online said that faulty psu can cause black screen/no signal. It made sense to me since psu is older than 5 years now. So i bought a new one installed it and guess what, black screen/no signal is still here. I'm losing it and i have no clue what to do anymore. I still think that cpu or mobo might be faulty. I would really appreciate some help.

My specs: RAM: Kingston 8gb ddr4 x2
GPU: Gtx 1070 8gb
CPU: i5 7400
MOBO: not really sure but it worked well for past 2 years.
PSU: ANTEC 750W EA750G Pro EC
 

Lutfij

Titan
Moderator
How old is the PSU in your build? What was the make and model of the PSU in your friend's build? Are the specs to your friend's build the same as yours(like for like)? If not, please detail it's specs for us to better understand the situation.

What that IT dude said was...makes no sense. Was he referring to the CPU socket pins? What pins was he referring to?

You will need to include the make and model of your motherboard, in order for us to move forward with troubleshooting.
 

ASK THE COMMUNITY

TRENDING THREADS