[SOLVED] PC wont boot with RAM in dual channel

Dec 10, 2020
3
0
10
0
Hey! I realize there are a dozen of these around the web, I have checked out pretty much each one of them and still haven't found a solution to this, so here goes:
I have recently switched out my old i5-4460 CPU with an i7-4790K, when I boot on my PC with the RAM in dual channel (A1+B1/A2+B2) the PC will either turn on and turn off after 3 seconds, or turn on and show no signal detected on my monitor - the latter happend after I cleared the CMOS by removing the battery for 5 minutes. I'll try to make this as detailed as possible...

Here are the following things, I have tried so far
Flashed to latest BIOS version 3602 (from 2108)
Cleared CMOS by removing the battery for 5 minutes
Set default settings in BIOS
Disabled fast boot option in BIOS (I read another with same problem having success with this)
Reseated the CPU about 4 times now
Checked for broken/bent pins with a magnifier
Switching back to my old i5-4460 CPU, dual channel works fine with it
Checked if my cooler was too tight or uneven (its a stock intel cooler, so I cant really put it too tight, since its determined by those plastic pins)
Set the voltage of the RAM to 1.5v
Tried plugging one RAM stick in each individual DIMM:
  • A1 - Computer turns on with monitor working
  • A2 - Computer turns on, no signal detected
  • B1 - Computer turns on with monitor working
  • B2 - Computer turns on, no signal detected
This is my setup
MB: B85M-G
RAM: HyperX Fury 1866 8gb DDR3 (x2)
CPU: i7-4790K
Cooler: CM stock cooler (seated with those plastic pins like the stock intel ones)
GPU: GTX 1060 6gb
PSU: CM 600w

If anyone got any more suggestions I'm really open to try everything out. I can also post settings of my BIOS too but its currently running with ALL default settings, nothing is or have ever been overclocked (neither is/was the GPU)
 

ASK THE COMMUNITY

TRENDING THREADS