Question Pc won't boot

misterangell

Reputable
Mar 29, 2015
7
0
4,510
0
So I have had this PC for some years. To be quite honest I have neglected the servicing of it and it has had better days with dust. However I have had no issues till today when I attempted to boot the PC and it just clicks, the fans slightly spin and it shuts off and it keeps trying to boot till I turn it off at the socket. I have stripped it apart and found that the cpu sata cable is causing the issue, I'm not an expert but I am looking at potentially a new cable or a new CPU?

Things I've tried
Cleaning
Resitting the ram chips

Things I haven't done
Took the water cooler off (no thermal paste as of yet)
Tried a different cable as I don't have any as of yet either

My question is could it be anything different, am I looking into the right area? And should I shed tears thinking about a replacement cpu

Specs
I7 4790k (not overclocked)
Asus maximus hero 5
Evga 850 g2
Gtx 970
Corsair ram chips 2 x 4gb
Windows 10
 

PC Tailor

Dignified
Herald
I have stripped it apart and found that the cpu sata cable is causing the issue,
What makes you say this? And presumably you just mean the CPU power cable? SATA is a different interface.
If it's simply that it doesn't boot loop when you unplug it, that's not indicative of a faulty CPU cable, that's the behaviour it tends to follow when you unplug it.

Cover each and every one of these steps first my friend :) https://forums.tomshardware.com/threads/perform-these-steps-before-posting-about-post-boot-no-video-problems.1285536/
 

stbean

Distinguished
Apr 23, 2012
12
0
18,510
0
I've encountered your same problem quite a few times and it usually was a result of a dying or dead PSU or connection issues with cables providing power to the mobo. I'm not saying that's your problem but something to look into.
 

ASK THE COMMUNITY

TRENDING THREADS