Question PC WONT BOOT

Apr 18, 2021
2
0
10
0
I built a pc i5 7400 and msi gym 1050ti x bv gaming graphics card
It turns on for a second and instantly shuts off I’ve looked at multiple post and YouTube videos and can’t figure out my issue
I bought a new gigabyte b365m ds3h motherboard and it does the same thing turns on for a second then shuts off my other motherboard is from cyber power pc b360m xtreme I have used 2 different brands of ram 1 16gb stick and the other time 2 8gb sticks both ddr4 ram I have unbuilt and built the pc multiple times making sure every wire is connected and disconnected every part like YouTube videos says to test if any is at fault and I’ve tried 2 different cpus bother working but nothing seems to work I’ve had it to only my 24pin power connector is connected and 8 pin cpu connected with the ram installed and still won’t boot I’ve also tried jumping my motherboard multiple times still have the same issue I’ve dumped over $700 in this pc someone please help me
 
Apr 18, 2021
2
0
10
0
I have also bought 2 different 700wAtt power supply’s and tested both brand new and i still have the same problem I’m flunked for what to do next
 

--SID--

Upstanding
Jan 23, 2021
417
111
390
9
i5-7400 is not compatible with B365 and B360 motherboard. 300 series chipset is for 8th and 9th gen cpus. You need a motherboard with 100 or 200 series chipset like B250.
Other option is to keep the motherboard and get a cpu like i5-8400/9400.
 

ASK THE COMMUNITY

TRENDING THREADS