Question PC won't boot

Apr 9, 2022
5
1
15
0
Hey guys,

Today my PC does not want to boot. I did not do any changes at all. It was perfectly functional untill yesterday.
When I turn on the PC it tries to boot for a while then it reboots itself. On the screen i see no signal so there is no way to get into bios.
I can see how the motherboard switches between the 2 nooses but it fails to load.

Below my components and what troubleshoot I already did:

Components:
Motherboard: aorus z390 pro
CPU: i7 9700k
Cooler: Corsair h60i pro
PSU: corsair Rm 650
Ram: 2x8gb Corsair vengeance pro 3000mhz
2x8gb Corsair vengeance pro 3600mhz
Video card: aorus master 3070 ti
SSD M2: aorus 256gb
SSD Sandisk ultra 256gb
2x hdd: 512 and 2tb from WD

Troubleshooting done:
  1. At first I tried to remove the ram with 3600mhz because in the past I had a similar issue until I figured it out how to set it up properly in bios.
  2. Remove the bios battery
  3. Remove the SSD M2 to see if I can alt leat to into bios
  4. Removed the video card and inserted it again
  5. Removed all the power cables and inserted them again
  6. Tried both ram slots with both 1 pair of RAM at the time
How can I figure it out which component is not working anymore :( i am desperate.
Could you please help me?
I also have a video of the issue

View: https://youtu.be/BHt54pUqTEY


Thanks in advance!
 

ASK THE COMMUNITY

TRENDING THREADS