Question PC won't connect to monitor ?

Jan 14, 2021
4
0
10
0
first off i bought an ibuypower prebuilt
asus rog motherboard
12 core 3800x cpu
2080 super
ssd etc

So my radiator went out and i replaced it with a kraken as the original wasn't very good anyway.
i literally plugged what i had to to get that switched and when plugging it in it says it’s not connecting to the monitor... no clue what it could be at this point
went through wires and made sure they’re in
reset battery 5 mins, reset the gpu.. lol i mean f***
ALL fans and lights work so i have no clue..
i dont think the cpu could’ve blown out that easy and wouldn’t the motherboard still give a beep code? it just starts up and sounds great lol
thanks for help.. gonna take it to microcenter and see if they can help me and will let you guys know what it was if ya cant help xD
 
Last edited:
beep codes u can get only for few things, CPU issues arent one of them for sure.
if u replaced just cooler and u 100% sure nothing got disconnected/broken during fan replacement, then u may need to look at your CPU/mainboard socket, for bent pints/dents
 
Jan 14, 2021
4
0
10
0
yes have tried both, multiple monitors on both hdmi and the monitor plug.. also just took out the ram and put it back in just incase, double checked wires again and nothing... im just confused why im not getting BIOS or anything
 
Jan 14, 2021
4
0
10
0
cpu and socket looks good... im wondering if it’s possible the cpu blew in the short window i had bios up before i shut it down? maybe 2 mins tops in that window
 

P_1___

Honorable
Nov 17, 2015
11
0
10,520
1
first off i bought an ibuypower prebuilt
asus rog motherboard
12 core 3800x cpu
2080 super
ssd etc

So my radiator went out and i replaced it with a kraken as the original wasn't very good anyway.
i literally plugged what i had to to get that switched and when plugging it in it says it’s not connecting to the monitor... no clue what it could be at this point
went through wires and made sure they’re in
reset battery 5 mins, reset the gpu.. lol i mean f***
ALL fans and lights work so i have no clue..
i dont think the cpu could’ve blown out that easy and wouldn’t the motherboard still give a beep code? it just starts up and sounds great lol
thanks for help.. gonna take it to microcenter and see if they can help me and will let you guys know what it was if ya cant help xD
You say the radiator went out , but not what happened.
Did any of the coolant leak onto the board?
 

ASK THE COMMUNITY

TRENDING THREADS