[SOLVED] PC Won't get 500Mb/s connection

pawcza

Reputable
Jul 26, 2016
7
0
4,520
1
Hi there,
I've recently asked my ISP to upgrade my connection speed from 60Mb/s to 500Mb/s. After a couple of days the change was made and I checked using Ookla's Speedtest, the speed test confirmed 128-130 Mb/s down and 28 Mb/s upload. I went forward and contacted my ISP assuming that something must be wrong on their end as I'm connecting via ethernet cable directly to their modem and my PC has a 1Gbps capable network card. They have sent an engineer through today who connected to the modem using the same cable (also the same slot) I'm using and he got stable 500Mb/s using same Ookla's speedtest website. I was shocked and started digging but nothing seems to be helping.

I'm running Windows 10 Pro x64 and my PC's MOBO is Asus PRIME B350-PLUS, apparently it's capable of running 1Gb/s speeds.
Things I've tried so far:
  • I'm not using any external network cards
  • Updated my LAN drivers from Asus website
  • Deleted old LAN drivers and installed new ones from Asus website
  • Made sure that Status window of my Ethernet connection says 1.0 Gbps (it does)
  • Played around with various settings in Realted PCIe GbE Controller Properties: Green Ethernet, Energy-Efficient Ethernet and Speed & Duplex
  • Tried running windows 10 in safe mode with networking (same speed results)
  • Using different speedtest (results vary but never go above 170Mb/s
  • Disabled Network Throttling in Registry
  • Tried looking in BIOS settings but can't find anything related to Network speeds.
  • Connecting to 5GHz wifi using my MacBook Pro and running a speedtest from Ookla gives me 470-490 Mbs
Is it possible it's a cable related issue IF the engineer used same cable and slot on the modem and gets a different result? Do you have any other suggestions on what may be causing it?
Thanks
 

pawcza

Reputable
Jul 26, 2016
7
0
4,520
1
If anyone ever stumbles on this thread this is what eventually fixed it for me:
Against all the guides regarding this problem you can find out there saying you should go to elevated cmd and set:
netsh int tcp set global autotuninglevel=disabled
I actually went forward and changed that to 'normal', so
netsh int tcp set global autotuninglevel=normal
after running ipconfig /renew & ipconfig /flushdns I can finally get 490-500Mb/s on a speedtest and the speed has improved A LOT.
 

Newtonius

Prominent
Sep 25, 2019
566
102
640
43
what kind of CAT cable is it? CAT 5 ethermet cables only get up to 100Mb/s speeds, it gets higher the shorter the cable is. If you have a CAT 5e or 6 Cable then the cable is not at fault (unless there's a cut in the cable somewhere) since they can reach 1Gb/s speeds.

Also is the modem a wireless router too? Try plugging directly into the router instead of the modem if you have that. Router ports are usually 1Gb as well.
 

pawcza

Reputable
Jul 26, 2016
7
0
4,520
1
I don't know how could I check if it's CAT 5 / 5e / 6. I was shocked that the engineer that visited plugged in the same cable (I unplugged it from my PC and gave it to him). The modem offers Wi-Fi as well but I'm running a wired connection on my PC. I've also tried Wi-Fi on my Mac and it does get 470-490 Mbs. I do also have TP-Link Archer C60 router but I'm not using it atm as I first want to resolve the problem before I move on to set up the router.
 
The cable should be marked on the side. It is highly unlikely you have cat5 those have not been made in years. Cat6 give you no advantage but it does not hurt anything if it is cheaper than cat5e. You need cat6a to run 10g.

What you want to see on the side of the cable is that it says EIA/TIA and also the wire size should be between 22-24. There is lots of fake cable on the market. If it says CCA it is not pure copper it is not a certified cable and will have issues.

Faulty cables are very strange they can work in some machine and not others. The speed can be affected if you are getting packet loss. You might be able to see it by running a ping to the router while the speed test is running. It does not always show up though and there is no indicator in pc or routers that show how many corrupted packets were discarded.

Since you can get the speed on the wifi (you must have been on top of the router) it mean the router and connection are fine. There are issues with CPU capacity on some routers.

I would try brand new cable just because it is cheap to try.

Be sure you do not have any of that stupid gamer network junk that is bundled with motherboards installed. The worst is killer but your board has realtek so it is not that. Asus bundles a similar program on some of their boards. Check that no netowrk accelerator stuff is loaded.
 

pawcza

Reputable
Jul 26, 2016
7
0
4,520
1
Thanks for your detailed answer.
At this point I've tried all 5 ethernet cables I've found at home. 1 is from Steam Link device, another one came bundled with Archer C60 router, another would be from BT Connection back in the UK, another I bought from Amazon and this one actually is the only one marked on the side and it says it's Cat 5E. Unfortunately I'm getting exactly the same results on all 5 cables (130 Mb/s on Ookla's Speed test).
I'll try buying another Cat 5E cable tomorrow if that helps.

Yeah when I tested Wi-Fi on Mac I was literally one meter away from the router (maybe even less)

I've tried piging my router while the speed test is running but I don't see any packet loses ( View: https://imgur.com/qp4DuSJ
)

I've also looked through my PC for any MOBO gaming related stuff included but there's nothing to be found

I have just updated my Chipset drivers as well but that didn't help at all
 
Maybe it is speedtest related. If you watch the network tab in the resource monitor and download a large file like a win10 image from microsoft do you see faster rates.

How fast does steam download. Steam reports rates in MByte so you need to convert.

The last test I can think of is if you have a second pc in the house. You can run a program called IPERF between the machines. You should see rates over 900mbps in both directions. This program test the port/cable/drivers. It is not affected much by stuff like cpu or memory or the OS.
 

pawcza

Reputable
Jul 26, 2016
7
0
4,520
1
Tried downloading .iso from Microsoft using their launcher but the speed would be capped at around 3.5 MB/s. Steam was acting weird because it would start off at 25MB/s but then drop down to 7-8MB/s and jump around after that. Usually not exceeding 12-15MB/s, sometimes even dropping out completely just to come back to 30MB/s. Generally it wasn't very stable. I tried P2P afterwards to acheive highest available speeds but that would get me to 16MB/s and nowhere higher so I guess that's what the speeedtest said.

I've also tried https://www.tenforums.com/network-sharing/53664-sudden-internet-speed-drop.html#post708234 this fix and
settings >> network & internet >> data usage >> background data >> enable to "Always"
as well but these wouldn't change a thing.

I'll try IPERF tomorrow since it wouldn't work between my PC <-> Mac I guess the ports are blocked and I don't have root access on the Mac so will need to get a windows laptop tomorrow.

___ Edit:

I don't have access to any other PC with Ethernet port at home but I've tried IPERF between a windows laptop on 5GHz Wi-Fi and my PC, it's showing 50-60 Mb/s transfer. I've also downloaded a ubuntu image yesterday (22-23MB/s on torrent) to try installing it today and testing on ubuntu. Also called my ISP to ask them to switch my modem to bridge mode (it won't allow me without calling the support line) and use my Archer C60 router. Will get back here after I get any results

Edit 2:
I've tried Ubuntu on the same machine today and I'm easily getting 500Mb/s on Ookla's speed test so this has to be windows/driver related
 
Last edited:

pawcza

Reputable
Jul 26, 2016
7
0
4,520
1
If anyone ever stumbles on this thread this is what eventually fixed it for me:
Against all the guides regarding this problem you can find out there saying you should go to elevated cmd and set:
netsh int tcp set global autotuninglevel=disabled
I actually went forward and changed that to 'normal', so
netsh int tcp set global autotuninglevel=normal
after running ipconfig /renew & ipconfig /flushdns I can finally get 490-500Mb/s on a speedtest and the speed has improved A LOT.
 

ASK THE COMMUNITY

TRENDING THREADS