Question PC Wont Post after upgrading to a ryzen 7 5800x

May 16, 2022
3
0
10
0
specs- ryzen 7 5800x, rog strix b550-f, 16gbs gskill ripjaws v 3600 , rtx2060. I have been ripping my hair out all day trying to figure out whats wrong with my pc and why it wont post. i have updated bios tried with 1 stick of ram, made sure all connector are plugged in, and still nothing it turns on with all the lights and fans but no post and the dram light just stays on. i really don't know what to do atm.
 

nicknegen

Distinguished
Feb 3, 2012
15
0
18,520
2
Ok unplug/remove anything that the pc doesn't need to post: expansion cards (other than your 2060, if you have them), hard drives, ssds, usb and front panel audio cables, etc. Would you happen to have another set of ram or another AM4 CPU?
 
May 16, 2022
3
0
10
0
Ok unplug/remove anything that the pc doesn't need to post: expansion cards (other than your 2060, if you have them), hard drives, ssds, usb and front panel audio cables, etc. Would you happen to have another set of ram or another AM4 CPU?
i do i have a ryzen 5 2600 and another am4 motherboard b450f. but i finally got it to boot with both cpus after completely dissembling my pc into the bare bones of it. i still dont really know what was causing it my guess it was a ssd or hardrive maybe ? im just happy i finally got it to post at least. thankyou for the help
 

nicknegen

Distinguished
Feb 3, 2012
15
0
18,520
2
Well its good that its working now. I would hook up one thing at a time and turn it on and see if it posts. Keep doing that until it doesn't post, then you've found your culprit.
 

nicknegen

Distinguished
Feb 3, 2012
15
0
18,520
2
It's also possible you might have had a short, or something was partially connected or pinched that caused it not to post, and taking it apart fixed it.
 

ASK THE COMMUNITY