[SOLVED] PC won't POST after upgrading ?

Nov 26, 2021
Went out and bought a Ryzen 7 5800X for my B450 Tomahawk Max and also bought 2 more of 3600 mghz ram of the same product that I already had. I have no idea what the issue is. The red LED for CPU is always on. I updated the BIOS to support Ryzen 7 5800X before installing everything. On the FIRST boot after installing all ram and CPU I was able to boot to bios but my dumbass forgot to plug in keyboard and mouse. They weren't working after plugging them in so I decided to turn off pc and turn it back on. Won't POST now.

  • -Flashed Bios twice with 2 different versions that supported my CPU using Bios Flash button.
  • -Took out CMOS battery for 1 min and put it back
  • -Jumped CMOS pins
  • -Individually put each RAM stick in each slot to see if RAM faulty
  • -Took out CPU and checked pins
Current Status: After flashing bios 2nd time, the PC restarted (did not happen on first bios flash) and now the Flash Bios button LED is always on (LED supposed to be off after update)

One last big issue, I accidentally bent the pins on my last CPU so I cannot check if my new CPU is the issue.

A long time ago when I got my ram, my PC wouldn't boot because my ram speed was at 3600 (too fast for CPU I think) and I turned it to 3200 and it worked.

When I originally got my PC to bios after upgrading it said the BIOS was flashed or something like that and my ram speed was defaulted at 2300 or something of that sort.

Please help lowkey panicking at this point. Thanks.

Edit 1: One more thing I should note is that when you boot up a PC using the B450 Tomahawk Max, the LEDS start blue and then quickly goes to red. After having issues with post, the LEDS are always stuck on blue. I have no idea what it means either since I cant seem to find out online.




[Verify that I found the applicable motherboard user manual.]

Double check the entire installation per the User Manual. Read through the manual first before doing anything and make notes to yourself about things to check and/or confirm.

For example: physically numbered Page 29 states:

" Always insert memory modules in the DIMMA2 slot first. "

Often overlooked.

However, there could be other reasons for the problems that are occurring.

Details matter.
Why can try to bend the pins back on your old CPU and see if it works and post?

Also whats your current GPU?, Have you tried to put it in a different x16 slot?

And I would suggest you test using your older RAM sticks only, since those were working previously.


Also whats your current GPU?, Have you tried to put it in a different x16 slot?
The POST check order is CPU -> RAM -> GPU since CPU is a prerequisite for initializing RAM and RAM is a prerequisite for initializing the GPU so if his motherboard is stuck at CPU, nothing else matters as his CPU appears to be brain-dead.

His bios flash LED being stuck on suggests that something has gone wrong there and his board might be in a bricked state.