Question PC wont post, have troubleshot, can’t seem to find the issue

Feb 22, 2019
I’m trying to figure out why my pc won’t post. This is my first ever build so excuse any noobiness.

My part list:

Asrock Extreme 4 Z370 Mobo
Intel 8700k Cpu
Rosewill Thor V2 Case
Corsair H115 AIO Unit
32 GB 2666 MHz Viper Ram
EVGA RTX 2070 Video Card
EVGA Supernova G3 850w Powersupply

My case didn’t come with speaker connectors for the motherboard, so currently I don’t have a beep code. Not sure if my mobo came with a cmos jumper, is it possible to still reset with a jumper?

The first time I put the pc together, I would turn on the power switch, it turned on but never showed anything on display. Initially I thought my case connectors wasn’t working either because the Corsair fans wouldn’t spin (but later found out I didn’t have the sata cables plugged correctly). After not understanding why it wouldn’t post with all the components inside the pc I removed then from the case and tried troubleshooting with just the motherboard, ram, psu, with and without the gpu and cooler.
When powered on, the motherboard lights turn on, one of the gpu fans spin (due to EVGAs initial curve settings possibly), the Corsair fans spin, the chasis fans spin but still no post.

I also tried:
-Double checking the seating of the MB on the standoffs,
-switching to vga connectors from hdmi,
-plugging vga and hdmi into motherboard instead of gpu.
Is it possible that this a motherboard issue even though the lights are on and fans spin?