Question pc wont post (ram or mobo issue)

Nov 24, 2021
So basically yesterday I got a new MOBO (GIGABYTE B560M DS3H V2 ), RAM ( 2x8GB CORSAIR DDR4 @3200Mhz), CPU (i5 11400f) and a new nvme m.2 256 SSD. So at first when I assembled everything and turned the pc on all the fans were running but I got no signal on my monitor. I tried resetting the cmos battery but nothing happened, I rechecked if everything is plugged in the right way I tried again and again with no success. Today I tried to run a single plate of RAM in every slot and again with no success until I got to RAM-slot 3. Finally my monitor caught signal and I cleanly installed windows. So out of curiousity I tried running the other plate in the same socket and again I got to boot. So after that I tried running both RAM sticks in slot 3 and 4 and I get stuck at some kind of a GIGABYTE screen that says F2 for m-flash and bios and 2 other options which I didn't memorise. When I try to press F2 nothing happens, I guess I have to use a PS2 keyboard which i currently dont own. Do you think it's worth buying one for the sake of trying? I'm open to all suggestion because I'm really desperate as you can see! :D