Question PC wont post suddenly

Mar 26, 2020
3
0
10
0
I have a Ryzen 1600x on a x470 gigabyte gaming wifi 5 with 16Gb ram (2x8), its been working perfectly fine for the past 2 years and somehow now it doesnt even post. My monitor just says that theres nothing connected and then just stays black. Ive tried everything, changing gpu, resetting cmos, jumpstarting battery and trying both RAM sticks one by one into each slot and nothing seems to work. Everything turns on and lights up im kinda outta options right now. The motherboard lights up, the cpu cooler lights up and spins, the gpu lights up and spins , the ram lights up.

It cant be the SSD or the GPU because it wont even post, its not the gpu as ive tried changing from DP to hdmi and switching GPU and also tried plugging the hdmi cable into the mb instead of the gpu

PS motherboard makes no sound/beep at all when i just let the system run for like 3 mins
 
What do the Status LEDs in the bottom right corner (near the SATA ports) of your motherboard show when you boot?

CPU/DRAM/VGA/BOOT (Status LEDs)
The status LEDs show whether the CPU, memory, graphics card, and operating system are working properly after system power-on. If the CPU/DRAM/VGA LED is on, that means the corresponding device is not working normally; if the BOOT LED is on, that means you haven't entered the operating system yet.

CPU: CPU status LED
DRAM: Memory status LED
VGA: Graphics card status LED
BOOT: Operating system status LED
 
Mar 26, 2020
3
0
10
0
What do the Status LEDs in the bottom right corner (near the SATA ports) of your motherboard show when you boot?

CPU/DRAM/VGA/BOOT (Status LEDs)
The status LEDs show whether the CPU, memory, graphics card, and operating system are working properly after system power-on. If the CPU/DRAM/VGA LED is on, that means the corresponding device is not working normally; if the BOOT LED is on, that means you haven't entered the operating system yet.

CPU: CPU status LED
DRAM: Memory status LED
VGA: Graphics card status LED
BOOT: Operating system status LED

The red led light at the bottom is changing between CPU and DRAM , there is no RED LED light on VGA or BOOT and the led on the gpu itself is white, have no clue what these indicate tho
 
Try to boot with as few parts as possible. Unplug your computer, remove the motherboards coin battery for at least 30 seconds. Disconnect any drives and only use 1 stick of RAM. You can also try moving your graphics card to the 2nd x16 slot. Then boot to see if you can get into the BIOS.
 
Mar 26, 2020
3
0
10
0
Tried all that you have listed above, and it still wont boot. Does that mean its a cpu and ram issue? since its still LED changing between CPU and DRAM on the motherboard?
 

ASK THE COMMUNITY