Question PC won't POST when I installed the RX 560

Jovan123

Reputable
Nov 13, 2015
18
0
4,510
0
I just bought the STRIX RX 560 4GB GPU. When I swapped it with the existing GPU and started the PC. The power light turned on, the CPU fans started running but stopped right away, and the PC is stuck in this state. Then I shut it down and swapped the old GPU back in. During startup it reported that the BIOS is corrupted and restored it from the backup version, but everything worked fine. At first I thought the BIOS might be the problem so I immediately updated the BIOS to the latest version and repeated the process. Same result except this time no corrupted BIOS. Then I tried again with every BIOS version but the results were the same.

Any help would be much appreciated :)

My specs:
CPU : FX-8300
MOBO : GA-970A-UD3P (rev 2.0)
RAM : one stick DDR3 8GB
PSU : Gigabyte 500W (can't remember the exact model)
OLD GPU : Radeon HD 5670

PS :
In the 6-pin slot on the RX, I plugged in the 6+2pin molex connector into the GPU, which is the only 6-pin connector I have. The white LED light on the RX next to the 6-pin slot lights up when the mobo is powered but I believe that's just a power indicator.
I put both GPU's in the only 16x PCI slot I have.
I read somewhere that RX 5xx are incompatible with any non UEFI BIOS, but my mobo's BIOS is UEFI so that shouldn't be a problem.

I've tested the RX on my friends PC and it starts up normally
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts