Question PC won't post, wondering if motherboard is dead

Nov 24, 2020
9
0
10
0
Hi,
I started building my pc today and it won't post. GPU and CPU fans starts up but, there is not screen. The peripherals (keyboard and mouse) won't light up either so, I think thinking it isn't posting.
Things I have tried:
  • Single ram instead of 2 in each slot
  • Resetting CMOS
  • Changing PSU
The system specs are:
Ryzen 5 3600
Hyperx fury 3200mhz (2*8gb)
Corsair MX650 PSU
Asus TUF B450 motherboard
GTX 780
Samsung evo 970 m.2 ssd
All the components are brand new except the graphics card which is tested working. I don't see any error LEDs or hear a beep. The CPU pins are intact and installed properly. The 8-pin ATX connector near CPU is also connected.

Any help would be appericiated.
 
Last edited:

RRichards

Reputable
Jul 2, 2017
44
4
4,565
5
So the motherboard and lighting is turning on but no video and no post? Seems like you might have a dead gpu. See if there's another system you can put it in or if you can get a hold of a cpu with an IGPU throw it in and see if you can get video out.
 
Nov 24, 2020
9
0
10
0
So the motherboard and lighting is turning on but no video and no post? Seems like you might have a dead gpu. See if there's another system you can put it in or if you can get a hold of a cpu with an IGPU throw it in and see if you can get video out.
I know that video card is working and shouldn't the motherboard POST without a gpu? I get that I can't get a output but POST should be possible. Unfortuanately, for me testing with another system is impossible, the only way is to go out and buy new parts which is why I am trying to narrow down the problem.
 
Nov 24, 2020
1
0
10
0
Since you've got a b450 motherboard it may require you to update the bios unless it said Ryzen 3000 ready. But, in order to update it, you need any previous-gen CPU to the Ryzen 3000 series. I think the other reason is that peripherals that aren't lighting up are due to the PC not posting.
 
Nov 24, 2020
9
0
10
0
Since you've got a b450 motherboard it may require you to update the bios unless it said Ryzen 3000 ready. But, in order to update it, you need any previous-gen CPU to the Ryzen 3000 series. I think the other reason is that peripherals that aren't lighting up are due to the PC not posting.
I did pick up motherboard which says Ryzen 3000 ready. I am worried about PC not posting without GPU. In theory it should atleast POST without any GPU and not show any output.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts