Question Pc wont post

May 24, 2019
4
0
10
Hi i need some help with my pc if anyone can figure it out.
I went on vacation for about 2 weeks and had my computer unplugged. I get back and go to start it up and nothing, all the fans are spinning and my 3 hdds are aswell but no beeps nor display.
I have rest the cmos, removed all non essential parts and tried it to no avail. In the past i have gottn beeps from having no ram but not when i tried this time. Does anybody know what the hell is going bc im at a loss. Thankyou in advance.

My specs are
Cpu c2q q9500
Mobo oem pulled from vostro 410
8gb of ddr2 ram all pulled frome 2 different oem pcs.
Gpu amd radeon hd 6750
Psu evga 600w 80plus
1 ssd 240
2 hdd 500
1 hdd 60

(And yes very weird system but im planning on upgrading all the components slowly as i do not have alot of money)
 

ConanLock

Proper
May 22, 2019
242
36
120
Hi, did you check to make sure that all of the connectors were in properly? Ensure that the connectors from the power button on the front panel are still in the motherboard alright, and that the 24 pin motherboard and 4 pin CPU connectors are still in too. Also, you might want to take out the CPU and check to make sure that is still in properly. Remember to unplug the PSU then press the power button before you do these to discharge any 'leftover' energy.
 
May 24, 2019
4
0
10
thanks for the quick reply. all the connectors were properly seated (i know this because when i pulled the mobo and did the whole checking which part it could be) also i did reseat the cpu which i forgot to mention and applied new thermal patse as it was needed. i did not try and see if the power buttons are in correctly so i will have to do that.
 
May 24, 2019
4
0
10
oh and thanks for the advice on the discharging the leftover energy thing i never thought about that i always thought i was good with just the wristband. (not being sarcastic im very new to pc building with my current pc being my first build)
 
May 24, 2019
4
0
10
update on the computer it turns the motherboard decided to crap out as i got a friend to loan me a 775 mobo that he had laying around. it booted right up with no problem. i still have no idea as what could have happened to the old one though. thankyou for the advice though.
 

ConanLock

Proper
May 22, 2019
242
36
120
Can you see any visible damage in your MoBo? Burnt/blown parts, bad capacitors etc. Motherboards do sometimes just decide to 'die' and as annoying as it is, there is usually not much to do about it.
 

ASK THE COMMUNITY

TRENDING THREADS