Question PC won't POST

Jun 6, 2021
2
0
10
0
HARDWARE
  • X570 Aorus Pro WiFi (Rev 1.2)
  • Ryzen 9 5900x
  • Vengeance RGB Pro Sl (2x 16GB)
  • Asus GeForce GTX 1650 Tuf Gaming
  • Galahad AIO 360
  • Seasonic GX-850 PSU
ISSUE:

Recently upgraded to the parts above with a new CPU/RAM and AOI cooler. The most notable being the CPU going from a 3000 series to a 5000 series. After a BIOS update I managed too get it working, but a few reboots later the machine refused to post. LED indicator seems to be complaining about my GPU (VGA light was on). I suspect some sort of issue with the BIOS but nothing I've tested seems to have helped. The GPU light is on and fans are spinning so it seems to be "working". For some reason my systems USB seem to be acting odd too, my Keyboard and Mouse doesn't light up, but other USB devices do.

ACTIONS:
  • Swappes out GPU
  • CMOS reset (PIN reset and by removing battery )
  • Flash older BIOS (F32)
  • Reseat RAM
  • Reseat/Checked Power Cables
  • Tried other PCIe slots
At this point I am at a lost of what to do, I may end up putting in the old CPU to see if it helps.

Update:

CPU swap allowed the machine to post, after it cycled its boot sequence twice. Went into a BIOs updating screen but then booted normally. I check my BIOS and the downgrade to F32 installed successfully. I am gonna try and add the CPU again before I conclude the CPU is faulty. Is there any setting in the BIOs I should be looking at first?

Final Update:

Seem to be a faulty CPU not even a days old and it failed. Regardless I'll be looking to get a replacement, there is still a possibility of it being an issue with the PSU, given the power draw would be might higher on the 5000 series CPU but given it worked prior I fine the CPU failing more likely
 
Last edited:
Jun 6, 2021
2
0
10
0
The cpu clock multiplier is the only thing I can think of, but expect that should update itself anyway.

I have heard about cases where increased core voltage have solved unstable systems, but for systems not posting at all i'm not sure.
It could have something to do with my PSU, but at this point its more likely to be the CPU swap as that seem to resolve the lack of posting
 

punkncat

Honorable
Ambassador
How old is the PSU?

A search indicated it is still being sold, and mentioned a 10 year warranty. If you have any suspicion it is going out, it could be worth pursuing. The output of it should be more than overkill for the system spec, even with the 5xxx Ryzen.

You mention swapping RAM, was this while you swapped the CPU? Did you default your stock profiles (XMP/OC) before doing the change?

IMO, start fresh back at the basic system settings that worked with your 3xxx CPU, the prior RAM. Make sure it's booting and stable. Do not use a memory overclock at this time. Keep everything stock. Update to the appropriate BIOS, and make sure you pay attention to if any other "bridge" BIOS has to be installed before landing on that final version.
Swap the (new) CPU in on the system with the original (working) RAM, on the stock board settings and see if it will boot. If it does, THEN proceed to swapping the RAM and working to see if it's XMP settings will work properly.
 

ASK THE COMMUNITY