Question PC won't power on after CPU upgrade, fried motherboard? HELP

new.good15

Reputable
Sep 24, 2017
9
0
4,510
0
Hello!. Yesterday I upgraded my cpu from a Ryzen 1600 (not longer have it) to a Ryzen 2600 (asus prime x-370 pro mobo running latest BIOS version) and the PC turns on but I don't get any post/signal nor the peripherals I plug in work. I've tried checking the CPU and reapplying thermal paste, clearing CMOS through the battery + jumper pin, I've tried a 2nd PSU and luck, reseatting the ram, taking off GPU.

Looks like power still travels throughout the motherboard powering components but I don't what's the issue here.

Could this be a case of a fried motherboard or a faulty PSU?

Update: The PC didn't turn on at all, now it powers on after I just disconnected everything from the motherboad, case fans, sata cables, front panel usb, audio, only lefe the 24 pin and the 6 pin cpu power connector, took off GPU, RAM, and the PC powers on. Maybe I can hook up the GPU and test if I get signal or something.
 
Last edited:

ASK THE COMMUNITY