Question PC won't start after removing CPU cooler

Aug 6, 2020
2
0
10
0
I recently had some thermal issues on my PC so I decided to check the CPU cooler. I took it out and nothing seemed off about it so I put back but now my PC won't start, fans dont start spinning or anything, no sign of life except my mouse turned on. Maybe I broke my motverboard? Please help

Specs:
Ryzen 5 2600
Asrock B450M Pro4
Rtx 2060
EVGA 500B
8GB HyperX ram
 

ThatSourMelon

Prominent
Apr 21, 2019
308
7
715
6
I recently had some thermal issues on my PC so I decided to check the CPU cooler. I took it out and nothing seemed off about it so I put back but now my PC won't start, fans dont start spinning or anything, no sign of life except my mouse turned on. Maybe I broke my motverboard? Please help

Specs:
Ryzen 5 2600
Asrock B450M Pro4
Rtx 2060
EVGA 500B
8GB HyperX ram
You only touched the cpu cooler? Check and make sure it’s plugged in the right place. If your Pc won’t turn on at all then that means there is something wrong in the path from you pushing the button to turn on the pc and it signaling the motherboard to turn on, double check and make sure everything is plugged into the right place.
 
Aug 6, 2020
2
0
10
0
You only touched the cpu cooler? Check and make sure it’s plugged in the right place. If your Pc won’t turn on at all then that means there is something wrong in the path from you pushing the button to turn on the pc and it signaling the motherboard to turn on, double check and make sure everything is plugged into the right place.
Yes I only touched the cooler and it's backplate. Peripherals light up when connected to the motherboard so that means the motherboard isn't broken right?
 
Sep 3, 2020
2
0
10
0
I recently had some thermal issues on my PC so I decided to check the CPU cooler. I took it out and nothing seemed off about it so I put back but now my PC won't start, fans dont start spinning or anything, no sign of life except my mouse turned on. Maybe I broke my motverboard? Please help

Specs:
Ryzen 5 2600
Asrock B450M Pro4
Rtx 2060
EVGA 500B
8GB HyperX ram
try taking off the CPU and putting it back again and see if it works, if not, check your cables
one day, after cleaning my pc, I was having some issues, my fans would turn on but shortly after this, my PC turned off, I just removed my RAM sticks and put them again (in the same place they were) and my PC came back to life, try doing this (if none of the other attempts worked)
 

gingerrankin

Estimable
Apr 3, 2018
779
18
2,715
206
What cooler are you using?
Make sure all cables are well connected, especially the 8/4 pin connector on the CPU.
Make sure you have not overtightened the cooler and that you have not damaged any possible insulating layers (this is a problem that happens often with the hyper 212).
Try booting with a single stick of DRAM.
 

ASK THE COMMUNITY